Bug 1435174 - The page is loaded slowly after click "add to project"
Summary: The page is loaded slowly after click "add to project"
Keywords:
Status: CLOSED DUPLICATE of bug 1471033
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.7.0
Assignee: Samuel Padgett
QA Contact: XiaochuanWang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 10:24 UTC by lichao
Modified: 2017-08-15 23:10 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-15 23:10:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1471033 medium CLOSED Sometime get "Failed to list templates/v1(undefined)" error in catalog console 2020-10-14 00:28:05 UTC

Internal Links: 1471033

Description lichao 2017-03-23 10:24:48 UTC
Description of problem:
When click the button "add to project", the next page is loaded very slowly. Pages except "add to project" page can be loaded quickly, such overview page.

Version-Release number of selected component (if applicable):
openshift v3.5.2
kubernetes v1.5.2+43a9be4

How reproducible:
always

Steps to Reproduce:
1. Get a project and click to overview page
2. Click to "add to project" button, and check the next page
3. Click "Ruby"


Actual results:
2. The next page is loaded very slowly, about 10s
3. The next page is loaded very slowly, about 10s


Expected results:
3 and 4: The next page is loaded quickly, like overview page which is about 2 s

Additional info:

Comment 1 Xingxing Xia 2017-05-09 11:05:05 UTC
In 3.6 service catalog testing, always found it is same slow and an circle is spinning about same seconds when loading the items under "Browse Catalog" (As comparison, SaaS offerings section can be loaded immediately). Seems the root cause is as same as comment 0?

Comment 2 Jessica Forrester 2017-05-09 14:24:11 UTC
The SaaS offerings aren't requesting anything from the server, that information is directly in JS config, so I'd expect that to load instantly like it is.

I recommend checking the network tab of the browser and seeing if any of the network requests on the catalog pages are taking a long time.  Check for imagestreams and templates.  This isn't something we see in our dev environments.

Comment 3 Xingxing Xia 2017-05-23 11:08:23 UTC
Sorry for late. Attached record of the browse catalog part spinning about 10s after login (or refresh), with network requests in screenshot.

Comment 15 shahan 2017-07-21 07:57:38 UTC
Now the "Add to project" was load very slowly, sometimes even exceed 1 min, please have a look. Thanks!

Test version:
OpenShift Master:v3.6.153

Comment 16 shahan 2017-07-21 08:00:57 UTC
Under the "Add to project", especially the 'Browse Catalog' tab is vvvery slowly, other two tabs are acceptable.

Comment 17 Jessica Forrester 2017-07-21 12:20:30 UTC
There is nothing we can do about this in 3.6, there are just that many templates OOTB and templates are huge because of all the objects they contain.

Comment 19 Samuel Padgett 2017-08-15 23:10:08 UTC
Marking this as a duplicate of 1471033 since it has the same underlying cause.

*** This bug has been marked as a duplicate of bug 1471033 ***


Note You need to log in before you can comment on or make changes to this bug.