Bug 1435206 - split-stack: heat configuration for clients endpoint_type is hardcoded to internal in the undercloud
Summary: split-stack: heat configuration for clients endpoint_type is hardcoded to in...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 11:53 UTC by James Slagle
Modified: 2017-05-17 20:12 UTC (History)
5 users (show)

Fixed In Version: instack-undercloud-6.0.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:12:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 448281 None None None 2017-03-23 11:54:23 UTC
Launchpad 1674822 None None None 2017-03-23 11:54:07 UTC

Description James Slagle 2017-03-23 11:53:39 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 James Slagle 2017-03-23 11:54:52 UTC
Bug Description:

The [clients]/endpoint_type configuration for heat.conf is hardcoded to internal in puppet-stack-config.pp for the undercloud. This means it's not possible to configure Heat to use any different endpoints other than the internal ones when talking to other OpenStack services or constructing url's.

The reason this should be configurable is because it could be desirable to reconfigure it to use the public endpoints in the case of using deployed servers where the ctlplane is not routable.

In such a scenario, you would want the deployed servers to poll swift temp url's and signal back to Heat over the public endpoints (via an ssl hostname which is routable) instead of the internal urls on the ctlplane which are not routable.

Comment 2 Emilien Macchi 2017-03-27 16:02:29 UTC
Moving to post; patches have been merged in master and backported in stable/ocata upstream. Now waiting for a new downstream build that would include the fix.

Comment 5 Gurenko Alex 2017-04-24 06:18:00 UTC
Verified on build 2017-04-20.2

[stack@undercloud-0 ~]$ rpm -q instack-undercloud
instack-undercloud-6.0.0-6.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:12:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.