Bug 1435212 - split-stack: no heat cfn api endpoint in the undercloud
Summary: split-stack: no heat cfn api endpoint in the undercloud
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 11.0 (Ocata)
Assignee: James Slagle
QA Contact: Gurenko Alex
URL:
Whiteboard:
: 1435211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 12:03 UTC by James Slagle
Modified: 2017-05-17 20:12 UTC (History)
4 users (show)

Fixed In Version: instack-undercloud-6.0.0-5.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:12:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 451453 None None None 2017-04-03 17:02:20 UTC
Launchpad 1674827 None None None 2017-03-23 12:04:16 UTC

Description James Slagle 2017-03-23 12:03:34 UTC
We are not creating the Heat cfn api endpoint in the undercloud. We should go ahead and create the endpoint since we are enabling the service. The endpoint is also needed if you are using deployed servers and want to configure the Heat polling and signaling to go over the public endpoints in the case where the ctlplane is not routable. In such a scenario, there needs to be a public endpoint for the cfn api created.

Comment 1 Alex Schultz 2017-03-24 16:55:13 UTC
*** Bug 1435211 has been marked as a duplicate of this bug. ***

Comment 2 James Slagle 2017-03-29 14:35:35 UTC
technically this is not a blocker, since we've documented using swift as the default signaling instead of CFN. since there are already public endpoints for swift created in the undercloud, this patch doesnt need to block 11.

i can't think of any reason why one would have to use CFN signaling. However, if there was one, this public endpoint would be needed.

Comment 3 Jaromir Coufal 2017-03-30 03:37:53 UTC
Removing blocker flag, let's try to still get it in OSP11.

Comment 4 Jon Schlueter 2017-04-03 17:02:21 UTC
stable/ocata backport merged

Comment 7 Gurenko Alex 2017-04-30 07:08:46 UTC
Verified on build 2017-04-20.2

[stack@undercloud-0 ~]$ . stackrc && openstack catalog list | grep heat-cfn
| heat-cfn         | cloudformation          | regionOne

Comment 8 errata-xmlrpc 2017-05-17 20:12:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.