Bug 143527 - grub not being installed into partition.
grub not being installed into partition.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-21 17:40 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 22:26:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2004-12-21 17:40:32 EST
Description of problem:
I have a Compaq R3000z (Athlon64) which has had this problem occur
although I believe it occurs on other platforms and may have been
reported against grub rather than anaconda (see
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=139140 ).


I have lots of disk space on the R3000z and after strinking the ntfs
partition for WinXP down to a reasonable level (8GB), I have installed
FC3 on the system (in fact, both i386 and x86_64 versions).  The disk
layout is:

/dev/hda1 -- WinXP (C-disk)
/dev/hda2 -- Linux swap
/dev/hda3 -- minimal FC3 install as "boot director" and
             grub installed into MBR
/dev/hda4 -- extended partion for rest of disk.
/dev/hda5 -- 15GB partition for FC3 i386
/dev/hda6 -- 15GB partition for FC3 x86_64
/dev/hda7 -- rest of disk for common /home

After installing the "boot directory" and getting it to boot up, I
added "chainloader +1" entried for hda5 and hda6 to /boot/grub/grub.conf

I then did everything installs of FC3 i386 and x86_64 into their
appropriate partitions.

I do not recall if I had any problems with the full i386 FC3 system
and I worked with it on the R3000z since I had to play around to get X
and other stuff configured correctly so things work.

Today, I started in on the x86_64 system ... oops, grub failed when it
tried to boot up.  OK, boot the install CDROM in rescue mode and run
grub from the chrooted system:

  root (hd0,5)
  setup (hd0,5)
  quit

Reboot but now it hags tring to do stage2.  OK, reboot the rescue
cdrom and run:

  grub-install  '(hd0,5)'

Then reboot and success!

While I found out how to get the system up and running, this should
not have occurred.
Comment 1 James R. Babb 2004-12-21 20:52:26 EST
this is a serious issue and should be delt with. 

this happened on a p4 2.4 ghz non-ht system.

I had no other partitions other than Linux mounted at / and linux swap.

But mostly I am glad to see that its not just me with the error.
Comment 2 Vasile Gaburici 2005-01-04 19:22:45 EST
I've had the same problem on an AMD768 system (dual Athlon MP) on a
clean install (deleted all existing partitions). I suspect that the
partitioning scheme is triggering this bug. This is the one I used
(from anaconda-ks.cfg):

#clearpart --linux
#part / --fstype "ext3" --size=15000 --asprimary
#part /zap --fstype "ext3" --size=20480 --asprimary
#part /tmp --fstype "ext3" --size=5000
#part /var --fstype "ext3" --size=5000
#part swap --size=2048
#part /lho --fstype "ext3" --size=1 --grow

Gene's solution worked for me too.
Comment 3 Jeremy Katz 2005-02-01 22:26:42 EST
Fixed with newer grub using O_DIRECT

Note You need to log in before you can comment on or make changes to this bug.