Bug 1435298 - Can't upload an instackenv.json file: Objects are not valid as a React child
Summary: Can't upload an instackenv.json file: Objects are not valid as a React child
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: RHOS Maint
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 14:05 UTC by Udi
Modified: 2017-05-17 20:13 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:13:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC

Description Udi 2017-03-23 14:05:57 UTC
Description of problem:
When trying to register nodes by uploading the instackenv.json to the GUI, you get this error:

Invalid JSON
Invariant Violation: Objects are not valid as a React child (found: [object XMLHttpRequest]). If you meant to render a collection of children, use an array instead or wrap the object using createFragment(object) from the React add-ons. Check the render method of `Notification`.

Registering the nodes one-by-one or via the CLI works.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-3.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Upload the instackenv.json file that's on the undercloud

Comment 1 Udi 2017-03-29 14:15:18 UTC
Verified in 2017-03-24.

Comment 4 errata-xmlrpc 2017-05-17 20:13:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.