Bug 1435320 - provider_mappings is wrong when using OpenDaylight
Summary: provider_mappings is wrong when using OpenDaylight
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Tim Rozet
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 14:25 UTC by Itzik Brown
Modified: 2018-10-18 07:25 UTC (History)
4 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-0.9.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
N/A
Last Closed: 2017-05-17 20:13:18 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 449849 None None None 2017-03-26 09:18:13 UTC
Launchpad 1675426 None None None 2017-03-23 14:25:24 UTC

Description Itzik Brown 2017-03-23 14:25:25 UTC
Description of problem:

/etc/puppet/hieradata/service_configs.json has the following:
"neutron::plugins::ovs::opendaylight::provider_mappings": "[\"datacentre:eth2\"]",

It ends up with the following mapping:
{local_ip="172.17.2.16", provider_mappings="[datacentre:eth2]"}

Which is wrong (There shouldn't be square brackets)

Version
=======
openstack-tripleo-heat-templates-6.0.0-0.20170307170102.3134785.0rc2.el7ost.noarch

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install OpenStack with opendaylight_v2 mechanism driver
2. On one of the overcloud nodes run: ovstbl=$(ovs-vsctl get Open_vSwitch . _uuid); sudo ovs-vsctl get Open_vSwitch $ovstbl other_config
3. Verify the output is similar to the output in the description

Actual results:


Expected results:


Additional info:

Comment 1 Itzik Brown 2017-03-26 05:56:55 UTC
Fix was merged u/s in stable/ocata

Comment 4 Itzik Brown 2017-04-03 07:12:18 UTC
Verified with:
openstack-tripleo-heat-templates-6.0.0-0.9.el7ost.noarch

Comment 6 errata-xmlrpc 2017-05-17 20:13:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.