Bug 143535 - Anaconda does not add HWADDR= entries in ifcfg-ethXX scripts
Summary: Anaconda does not add HWADDR= entries in ifcfg-ethXX scripts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kudzu   
(Show other bugs)
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-21 23:20 UTC by jordan hargrave
Modified: 2007-11-30 22:07 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 19:37:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jordan hargrave 2004-12-21 23:20:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041107 Firefox/1.0

Description of problem:
On a fresh system install, the entries in
/etc/sysconfig/network-scripts/ifcfg-ethXXX are created.  However
theres is no HWADDR= field in these scripts.  If additional network
cards are added to the system after installation, kudzu cannot
synchronize the network configuration properly.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install RHEL4 pre-rc2
2.check /etc/sysconfig/network-scripts/ifcfg-ethXX
3.
    

Actual Results:  There are no HWADDR= entries in the scripts after
installation

Expected Results:  The HWADDR field should be populated.  If
additional cards are added/removed, kudzu cannot synchronize its state
properly.

Additional info:

Comment 1 Jeremy Katz 2004-12-22 22:49:06 UTC
This is caused by kudzu somehow not being able to assign an ethX to
NICs again.

Reverting back to kudzu.c:1.125 fixes that but that's not a real fix.

cc'ing Bill, but he's on vacation so I'll look at this some more
tonight/tomorrow.

Comment 2 Jeremy Katz 2004-12-23 15:47:28 UTC
Instead of changing kudzu, I made a change to anaconda to get the
hwaddr even in cases where kudzu can't do the device mappings and just
excluded setting the HWADDR on s390 to avoid hitting bug 135023.

Comment 3 Amit Bhutani 2005-01-14 19:14:27 UTC
Appears fixed in RC1. Will leave it open so Jordan can confirm and 
close when he's back from vacation (1/17).

Comment 4 jordan hargrave 2005-01-21 19:37:52 UTC
Confirmed that this is now fixed in RC1


Note You need to log in before you can comment on or make changes to this bug.