Bug 1435385 - Missing options for hammer host create/update subcommands
Summary: Missing options for hammer host create/update subcommands
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.2.9
Hardware: Unspecified
OS: Unspecified
high
medium vote
Target Milestone: Unspecified
Assignee: Shimon Shtein
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 16:43 UTC by Roman Plevka
Modified: 2019-06-13 21:25 UTC (History)
11 users (show)

Fixed In Version: rubygem-katello-3.0.0.124-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)
Index of api docs in json (862.27 KB, text/plain)
2017-04-13 08:47 UTC, Tomas Strachota
no flags Details
Api docs for host create in json (19.56 KB, text/plain)
2017-04-13 08:48 UTC, Tomas Strachota
no flags Details

Description Roman Plevka 2017-03-23 16:43:03 UTC
The following subcommands are no longer available in 6.2.9-1 compose. Looks like they still exist in nightly, so I believe it might be a packaging bug.

Description of problem:
E           AssertionError: 
E           hammer host create
E             Removed options:
E               * lifecycle-environment
E               * release-version
E               * autoheal
E               * lifecycle-environment-id
E               * content-view-id
E               * service-level
E               * kickstart-repository-id
E               * hypervisor-guest-uuids
E               * content-view
E           
E           hammer host update
E             Removed options:
E               * lifecycle-environment
E               * release-version
E               * autoheal
E               * lifecycle-environment-id
E               * content-view-id
E               * service-level
E               * kickstart-repository-id
E               * hypervisor-guest-uuids
E               * content-view

# rpm -qa *hammer*
tfm-rubygem-hammer_cli_import-0.11.2-1.el7sat.noarch
tfm-rubygem-hammer_cli_katello-0.0.22.28-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.5.1.10-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.6-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_admin-0.0.5-1.el7sat.noarch
tfm-rubygem-hammer_cli-0.5.1.13-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.0.5.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_csv-2.2.1.1-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.10.3-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_discovery-0.0.2.3-1.el7sat.noarch


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. hammer host create --help
2. hammer host update --help


Actual results:
above options not available

Expected results:
above options available

Additional info:

Comment 7 Daniel Lobato Garcia 2017-04-12 08:04:37 UTC
Moving to component Hammer

Comment 9 Tomas Strachota 2017-04-13 08:47:20 UTC
Created attachment 1271358 [details]
Index of api docs in json

Comment 10 Tomas Strachota 2017-04-13 08:48:51 UTC
Created attachment 1271359 [details]
Api docs for host create in json

Comment 11 Tomas Strachota 2017-04-13 08:51:58 UTC
I'm not sure what causes the problem but I can confirm there's probably some issue with order of loading plugins and generating apipie cache during installation.

Docs for host create action in apidoc index file "v2.json" lack all attributes that come from facets. Apidoc file "create.json" with action details that should serve as a source for "v2.json" is correct. When I trigger foreman-rake apipie:cache on the server, facet related attributes disappear even from "create.json".

See attached v2.json and create.json apidoc exports from a clean 6.2.9 installation (before foreman-rake apipie:cache was run).

Comment 14 Satellite Program 2017-04-23 21:38:53 UTC
Created redmine issue http://projects.theforeman.org/issues/19355 from this bug

Comment 21 Roman Plevka 2017-04-26 14:06:56 UTC
VERIFIED
on 6.2.z-5 by automation

Comment 22 Bryan Kearney 2017-05-01 14:28:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191

Comment 23 Bryan Kearney 2017-05-01 14:29:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.