Bug 1435394 - Ipa-kra-install fails with weird output when backspace is used during typing Directory Manager password
Summary: Ipa-kra-install fails with weird output when backspace is used during typing ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Abhijeet Kasurde
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 17:24 UTC by Petr Vobornik
Modified: 2017-08-01 09:46 UTC (History)
5 users (show)

Fixed In Version: ipa-4.5.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Petr Vobornik 2017-03-23 17:24:20 UTC
Cloned from upstream: https://pagure.io/freeipa/issue/6738

Steps to reproduce:
1) Install ipa-server 
2) Run: # ipa-kra-install 
3) When installation asks for Directory Manager password hit "Backspace"
4) Press enter
5) Installation failed with really weird output: 
Failed to configure KRA instance: Command 'XXXXXXXX ... lot of lines of 'X' chars ... XXXXX' returned non-zero exit status 1

Comment 2 Petr Vobornik 2017-03-23 17:24:38 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6738

Comment 3 Petr Vobornik 2017-03-23 17:26:48 UTC
ipa-4-5:

    8f0c7df198f8dd6ae742b099b3258c2383007c30 ipapython.ipautil.nolog_replace: Do not replace empty value
    master:

    4297ad6db0d4f39d82fd155323163df92b2b7894 ipapython.ipautil.nolog_replace: Do not replace empty value
    ipa-4-4:

    40e1eb695d648a03f45e9c8d6687cb3d8a99fd6d ipapython.ipautil.nolog_replace: Do not replace empty value

Comment 5 Abhijeet Kasurde 2017-05-25 09:53:40 UTC
Verified using IPA server version :: ipa-server-4.5.0-13.el7.x86_64

Wrong DM's password

[root@qe-blade-13 ~]# ipa-kra-install
Directory Manager password:

Directory Manager password is invalid
The ipa-kra-install command failed. See /var/log/ipaserver-kra-install.log for more information

Backspace as DM's password

[root@qe-blade-13 ~]# ipa-kra-install
Directory Manager password:

Server is unwilling to perform: Unauthenticated binds are not allowed
The ipa-kra-install command failed. See /var/log/ipaserver-kra-install.log for more information

Marking BZ as verified.

Comment 6 errata-xmlrpc 2017-08-01 09:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.