Bug 143545 - aic7xxx does not detect medium changers on pv122t
aic7xxx does not detect medium changers on pv122t
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Paradis
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 00:18 EST by Rob Kearey
Modified: 2013-08-05 21:10 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-13 19:14:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Kearey 2004-12-22 00:18:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20040929

Description of problem:
When booting a machine with an Adaptec AHA-3960D / AIC-7899A U160/m with an attached Dell PowerVault 122t dlt autoloader, the medium changer devices on LUN 1 of the device is incosistently detected. With one PV122t plugged in the tape serial device and the medium changer device are detected [as st0 and sg2]. With another PV122t plugged in on the other channel both st0 and st1 are detected, but not sg devices are detected at all. 

/proc/scsi/scsi shows


Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SEAGATE  Model: ST336753LW       Rev: DX09
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: SEAGATE  Model: ST336753LW       Rev: DX09
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: BNCHMARK Model: VS640            Rev: 5639
  Type:   Sequential-Access                ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 06 Lun: 00
  Vendor: BNCHMARK Model: VS640            Rev: 5032
  Type:   Sequential-Access                ANSI SCSI revision: 02

The devices need to be manually added with:

echo "scsi add-single-device 0 0 6 1" > /proc/scsi/scsi
echo "scsi add-single-device 1 0 6 1" > /proc/scsi/scsi

which gives

Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SEAGATE  Model: ST336753LW       Rev: DX09
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 01 Lun: 00
  Vendor: SEAGATE  Model: ST336753LW       Rev: DX09
  Type:   Direct-Access                    ANSI SCSI revision: 03
Host: scsi0 Channel: 00 Id: 06 Lun: 00
  Vendor: BNCHMARK Model: VS640            Rev: 5639
  Type:   Sequential-Access                ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 06 Lun: 01
  Vendor: BNCHMARK Model: VS640            Rev: 5639
  Type:   Medium Changer                   ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 06 Lun: 00
  Vendor: BNCHMARK Model: VS640            Rev: 5032
  Type:   Sequential-Access                ANSI SCSI revision: 02
Host: scsi1 Channel: 00 Id: 06 Lun: 01
  Vendor: BNCHMARK Model: VS640            Rev: 5032
  Type:   Medium Changer                   ANSI SCSI revision: 02

sg numbering seems suspect too (sg3 and sg5?).





Version-Release number of selected component (if applicable):
2.4.9-e.57smp, 2.4.9-e.57

How reproducible:
Always

Steps to Reproduce:
1. Add extra tape autoloader device
2. Reboot
3. Watch sg module seemingly not be loaded with any consistency
  

Actual Results:  sg devices are not consistently displayed in /proc/scsi/scsi and are undetected

Expected Results:  /proc/scsi/scsi should accurately reflect what's on the scsi busses.

Additional info:
Comment 1 Rob Kearey 2004-12-22 00:33:10 EST
I'm doing a post-install modprobe sg, and the add-single-device in rc.local. Is
the aic7xxx driver just not scanning luns?

Comment 2 Rob Kearey 2004-12-22 00:34:45 EST
Same results with aic7xxx_mod
Comment 3 Rob Kearey 2004-12-22 19:46:00 EST
Whoops, my mistake, was doing this with e.49, re-testing with e.57 now.
Comment 4 Rob Kearey 2004-12-22 19:46:55 EST
same problem occurs with e.57
Comment 5 Rob Kearey 2004-12-22 20:04:04 EST
same results for e.57 with aic7xxx_mod
sysreport available.
Comment 6 Jim Paradis 2005-10-26 20:14:46 EDT
Does this problem occur with the most recent RHEL2.1 kernel?
Comment 7 Jim Paradis 2006-09-13 19:14:22 EDT
Due to lack of response from reporter and the current support status of RHEL2.1,
I am closing this as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.