Bug 1435481 - Document Improved container support required for OSP
Summary: Document Improved container support required for OSP
Keywords:
Status: CLOSED DUPLICATE of bug 1568087
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-High_Availability_Add-On_Reference
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 7.4
Assignee: Steven J. Levine
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
: 1444212 (view as bug list)
Depends On: 1432722 1433016
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-23 23:02 UTC by Ken Gaillot
Modified: 2019-03-06 01:05 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1433016
Environment:
Last Closed: 2018-08-22 19:14:09 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ken Gaillot 2017-03-23 23:02:44 UTC
+++ This bug was initially created as a clone of Bug #1433016 +++

Pacemaker and pcs are adding enhanced support for Docker containers. There will be a completely new syntax that will need to be documented. The feature will likely be in Tech Preview for general use for 7.4, although it will be fully supported for use by our OpenStack installer.

There will be a new resource type (in addition to primitive, group, etc.) to define a "bundle", consisting of Docker settings, network settings, storage settings, and the service being containerized.

Details are still being ironed out; watch the parent bug for details.

Comment 2 Steven J. Levine 2017-07-27 20:37:05 UTC
*** Bug 1444212 has been marked as a duplicate of this bug. ***

Comment 3 Steven J. Levine 2017-10-02 20:48:04 UTC
Ken:

I'm looking at the 7.5 features to document, and I'm not sure where to take the issue of documenting bundles.  For 7.4, when this feature was in tech. preview, this is all that we said:
-------------

The pcs tool now manages bundle resources in Pacemaker

As a Technology Preview starting with Red Hat Enterprise Linux 7.4, the `pcs` tool supports bundle resources. You can now use the "pcs resource bundle create" and the "pcs resource bundle update" commands to create and modify a bundle. You can add a resource to an existing bundle with the "pcs resource create" command. For information on the parameters you can set for a `bundle` resource, run the "pcs resource bundle --help" command.
----------------

But maybe we should talk about this a little more, with an example?  This seems tied in to managing galera and rabbit so I'm not sure what we can or should document here.  This might perhaps be an article on the Portal?

Any thoughts on whether and what we need to document for 7.5, and whether that could be a chapter in the Reference or an article?

Is there existing documentation I should know about?

Comment 4 Ken Gaillot 2017-10-03 22:36:43 UTC
Bundles are tied to galera and rabbit only in the context of OpenStack. When we take this out of tech preview (which I believe will be 7.5), bundles can be used with any resource that can be put into a Docker container.

Upstream has this documentation for the equivalent of 7.4:

* http://clusterlabs.org/doc/en-US/Pacemaker/1.1-pcs/html-single/Pacemaker_Explained/index.html#s-resource-bundle

* https://wiki.clusterlabs.org/wiki/Bundle_Walk-Through


The upstream equivalent of 7.5 will have these changes:

* https://github.com/ClusterLabs/pacemaker/commit/3d7b32a586188024301acc7d2ac50649e299fe50

* https://github.com/ClusterLabs/pacemaker/commit/d7735f24316da16e52f3cd07876373d52baa42e2


However we could use a much simplified form of all that for RHEL. RHEL won't support rkt containers, so that can be left out. And of course we would document pcs commands rather than the raw XML.

Looking at the upstream walk-through, we'd have to replace the parts about where to find the docker package and which base image to use.

There's also a chance we could leave this tech preview for 7.5, in which case all this could be deferred.

Comment 8 Steven J. Levine 2018-03-19 13:51:09 UTC
Adding Mikey Ariel to the CC list for this BZ -- Mikey works on OpenStack HA docs which need to be coordinated with the documentation we'll be providing here.


Note You need to log in before you can comment on or make changes to this bug.