Bug 143553 - smartd seg faults on startup
smartd seg faults on startup
Status: CLOSED DUPLICATE of bug 124412
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel-utils (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 03:07 EST by Dirk Gfroerer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-23 03:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of smartd startup (4.46 KB, text/plain)
2004-12-22 03:09 EST, Dirk Gfroerer
no flags Details

  None (edit)
Description Dirk Gfroerer 2004-12-22 03:07:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040924

Description of problem:
I'm trying to monitor my SCSI disks in a Dell PowerEdge 1800 system
using smartd. /etc/smartd.conf consists out of two lines:

/dev/sda -H -m digf@ghlx02
/dev/sdb -H -m digf@ghlx02

But smartd fails with a segmentation fault on startup. This might be
related to bug 124412 but this bug doesn't seem to make any progress.

Version-Release number of selected component (if applicable):
kernel-utils-2.4-8.37.7

How reproducible:
Always

Steps to Reproduce:
1. Add the SCSI disks to /etc/smartd.conf
2. Start smartd

    

Actual Results:  Smartd segfaults.

Expected Results:  Smartd starts and monitors the devices.

Additional info:
Comment 1 Dirk Gfroerer 2004-12-22 03:09:05 EST
Created attachment 108993 [details]
strace of smartd startup
Comment 2 Tomas Mraz 2005-11-23 03:48:07 EST

*** This bug has been marked as a duplicate of 124412 ***

Note You need to log in before you can comment on or make changes to this bug.