Bug 1435570 - [RFE] - provide a way for the user to modify mount_options once hosted engine is deployed.
Summary: [RFE] - provide a way for the user to modify mount_options once hosted engine...
Keywords:
Status: CLOSED DUPLICATE of bug 1359265
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.1.1.2
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Doron Fediuck
QA Contact: meital avital
URL:
Whiteboard:
: 1435569 (view as bug list)
Depends On: 1373930
Blocks: Gluster-HC-3
TreeView+ depends on / blocked
 
Reported: 2017-03-24 09:18 UTC by RamaKasturi
Modified: 2018-07-09 11:18 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-08 16:11:11 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1386497 None NEW [RFE] support usage of multiple luns for Hosted Engine storage 2019-04-08 19:37:12 UTC

Internal Links: 1386497

Description RamaKasturi 2017-03-24 09:18:46 UTC
Description of problem:
currently, there is no way for the user to modify mount_options once HE is deployed. Due to this when ever a node is replaced user will not be able to modify mount_options for hosted_storage. This is really important for hc use case to avoid SPOF.

Version-Release number of selected component (if applicable):
ovirt-engine-4.1.1.2-0.1.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install HC setup
2. Replace a failed node in the HC setup.
3.

Actual results:
There is no way for the user to change the mnt_options for the hosted_storage once HE is deployed.

Expected results:
There should be an option for the user to change mnt_options 

Additional info:
Within /etc/ovirt-hosted-engine/hosted-engine.conf we have a pointer to the shared storage used for the engine VM since the host has to be able to mount it also when the engine VM is still not up.
This contains also mnt_options filed with backup-vol file-servers  which is required to prevent a storage SPOF.

The point is that /etc/ovirt-hosted-engine/hosted-engine.conf is written by ovirt-hosted-engine-setup for the first host and by host-deploy on additional hosts while now we need also to update it when the user wants to replace one of the initial three hosts.

Comment 1 Yaniv Kaul 2017-03-26 07:13:47 UTC
Dup of bug 1435569 ?

Comment 2 Yaniv Lavi 2017-03-27 09:10:41 UTC
*** Bug 1435569 has been marked as a duplicate of this bug. ***

Comment 3 RamaKasturi 2017-03-27 11:32:07 UTC
(In reply to Yaniv Kaul from comment #1)
> Dup of bug 1435569 ?

yes, it is a duplicate. First time i submitted it i got an error and was not sure if it was logged, so logged it again.

Comment 4 Yaniv Kaul 2017-06-07 13:00:16 UTC
Is it different than bug 1359265 ?

Comment 5 Doron Fediuck 2017-06-08 16:11:11 UTC

*** This bug has been marked as a duplicate of bug 1359265 ***

Comment 6 Nikolai Sednev 2018-03-28 12:11:34 UTC
The initial idea of this RFE was to let customer replace failed ha-host with another ha-host, while letting customer to change mounting options for already deployed and existing hosted_storage.

https://bugzilla.redhat.com/show_bug.cgi?id=1373930#c22 is about fresh and clean SHE deployment using vintage flow, with mounting options.

In which way this RFE is duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1373930?

Comment 7 Nikolai Sednev 2018-03-29 05:39:00 UTC
Returning back need info.
Doron, please provide your input.


Note You need to log in before you can comment on or make changes to this bug.