Bug 143563 - up2date causes rpm db error.
up2date causes rpm db error.
Status: CLOSED DUPLICATE of bug 143532
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 07:09 EST by Xander D Harkness
Modified: 2016-06-07 18:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xander D Harkness 2004-12-22 07:09:25 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
I have my machines set to automatically update from RHN using up2date.

I am using up2date-4.2.38-1

rpm -q up2date
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
package up2date is not installed

Version-Release number of selected component (if applicable):
up2date-4.2.38-1 rpm-4.2.3-13

How reproducible:
Always

Steps to Reproduce:
1. Have RHEL3 machines with full pre U4 update
2. Set machine to automatically update from RHN
3. The machine will not complete U4 update owing to error on rpm db
    

Actual Results:  rpm -q up2date
rpmdb: Program version 4.2 doesn't match environment version
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
package up2date is not installed


Expected Results:  rpm -q rpm
rpm-4.2.3-13

Additional info:

To fix the problem remove the following files:
/var/lib/rpm/__db.00[1,2,3]
Comment 1 Xander D Harkness 2004-12-22 09:33:06 EST

*** This bug has been marked as a duplicate of 143532 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.