Bug 143583 - New fix in glibc breaks rpm functionality
New fix in glibc breaks rpm functionality
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 10:49 EST by Pauline Middelink
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-22 16:49:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pauline Middelink 2004-12-22 10:49:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.3)
Gecko/20040930

Description of problem:
From the changelog:
--------------------
* Wed Oct 06 2004 Jakub Jelinek <jakub@redhat.com> 2.3.2-95.28
- fix glob on dangling symlinks

This fix kills the notion of having a glob in a spec file for a
directory with files. In case of compiling redhat-config-netboot, but
there are many others, a link is placed in /usr/bin pointing to a file
which is not included in this package (consolehelper). In the past
this was valid, not anymore since the glob no longer sees the
dangeling link.

Version-Release number of selected component (if applicable):
glibc-2.3.2-95.30

How reproducible:
Always

Steps to Reproduce:
1. install before mentioned glibc
2. rpmbuild --rebuild -b redhat-config-netboot
    

Actual Results:  rpm packaging error.

Expected Results:  rpm package with the dangling link into place

Additional info:

Running the exact same steps on a system which is totally upgraded
EXCEPT glibc results in the expected package. Problem lays in
interaction rpm vs glibc
Comment 1 Ulrich Drepper 2004-12-22 16:49:12 EST
The change is correct and necessary.  If .spec files have problems they need to
be fixed.

Note You need to log in before you can comment on or make changes to this bug.