Bug 1435837 - Error parsing PCC subspaces from PCCT
Summary: Error parsing PCC subspaces from PCCT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Al Stone
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1468315 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-24 23:48 UTC by Dimitris
Modified: 2018-06-05 17:36 UTC (History)
72 users (show)

Fixed In Version: kernel-4.16.12-300.fc28 kernel-4.16.12-200.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-29 11:20:09 UTC


Attachments (Terms of Use)
Dump of dmesg which contains the PCCT error message (87.53 KB, text/plain)
2017-06-14 05:46 UTC, Max Roeleveld
no flags Details
/sys/firmware/acpi/tables/PCCT from a Dell laptop (110 bytes, application/octet-stream)
2018-03-20 09:45 UTC, Aleksei Kovura
no flags Details
/sys/firmware/acpi/tables/FACP from a Dell laptop (268 bytes, application/octet-stream)
2018-03-20 09:46 UTC, Aleksei Kovura
no flags Details
FADT and PCCT tables for ThinkPad T450s (804 bytes, application/x-gzip)
2018-03-20 19:51 UTC, Romualdas Mincevicius
no flags Details
/sys/firmware/acpi/tables/FACP from an ASUS ROG G551JW (268 bytes, application/octet-stream)
2018-03-28 02:21 UTC, Franco Geller
no flags Details
/sys/firmware/acpi/tables/PCCT from an ASUS ROG G551JW (110 bytes, application/octet-stream)
2018-03-28 02:23 UTC, Franco Geller
no flags Details
patch 1/3 -- simple documentation fix only (1.73 KB, patch)
2018-04-04 21:19 UTC, Al Stone
no flags Details | Diff
patch 2/3 -- fix a possible subtable parsing issue (2.29 KB, patch)
2018-04-04 21:20 UTC, Al Stone
no flags Details | Diff
patch 3/3 -- correct bogus error message about PCCT (9.09 KB, patch)
2018-04-04 21:21 UTC, Al Stone
no flags Details | Diff
FACP from Sony Vaio Pro 13 (268 bytes, application/octet-stream)
2018-04-23 06:09 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
PCCT from Sony Vaio Pro 13 (110 bytes, application/octet-stream)
2018-04-23 06:11 UTC, Dominik 'Rathann' Mierzejewski
no flags Details
Upstream patch (as accepted in linux-pm) (10.13 KB, patch)
2018-05-24 17:41 UTC, Al Stone
no flags Details | Diff

Description Dimitris 2017-03-24 23:48:28 UTC
Description of problem:

Newly appeared warning during boot:

Error parsing PCC subspaces from PCCT

Version-Release number of selected component (if applicable):

4.10.5-200.fc25.x86_64

How reproducible:

Every time, on boot

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Machine is a Thinkpad X250 on BIOS 1.24, booting in legacy mode.  No dual/multi-boot, just Fedora.

This is new with kernel 4.10.5-200.fc25.x86_64

Kernel command line:

BOOT_IMAGE=/vmlinuz-4.10.5-200.fc25.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-f2300f39-1b39-4d66-9621-567d5ca4e2bf rd.lvm.lv=fedora/swap resume=/dev/mapper/fedora-swap acpi_osi=Linux rhgb quiet LANG=en_US.UTF-8

I've also tried without acpi_osi=Linux and without the resume argument, no change.

No apparent ill effect so far, just wanted to report this and get to the bottom of how to fix (do I have to go back to UEFI/Secure Boot?)

Comment 1 AsshatAdmiral 2017-03-30 01:25:52 UTC
I can confirm having the same issue on Fedora 25. Only started to manifest once I upgraded to the 4.10 kernel and rebooted.

My machine:
Dell XPS 13 9343
BIOS version A11, legacy mode, Fedora only.

Kernel:
Command line: BOOT_IMAGE=/vmlinuz-4.10.5-200.fc25.x86_64 root=/dev/mapper/korora-root ro rd.lvm.lv=korora/root rd.luks.uuid=luks-00501775-2acd-4813-bade-c22c8497dbba rd.lvm.lv=korora/swap rhgb quiet LANG=en_US.UTF-8

Error shows up in the dmesg here:
[    0.247939] Error parsing PCC subspaces from PCCT

And appears on the screen right before GDM displays.

Let me know if there's any other information I can provide to be of assistance.

Comment 2 Dmitri Smirnov 2017-03-30 11:11:30 UTC
Can confirm having the same issue with Lenovo Thinkpad T450s, started after update to 4.10. Updating BIOS from 1.25 to 1.28 didn't help.

Thinkpad T450s, booting in UEFI with SecureBoot

# dmidecode -s bios-version && dmidecode -s bios-release-date                                                
JBET64WW (1.28 )
03/16/2017

# uname -a                                                                                                 
Linux zalando-24032 4.10.6-200.fc25.x86_64 #1 SMP Mon Mar 27 14:06:23 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Kernel boot parameters are all default.

Comment 3 tony 2017-03-31 20:40:00 UTC
I have the same problem. 

I have a lenovo 450s with 20Gb RMA.

[root@charon ~]# dmidecode -s bios-version && dmidecode -s bios-release-date
JBET56WW (1.21 )
01/27/2016

[root@charon ~]# uname -a  
Linux charon 4.10.6-200.fc25.x86_64 #1 SMP Mon Mar 27 14:06:23 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[root@charon ~]# 


I installed VMWARE workstation Pro version - 12.5.5 build-5234757 which is when i started seeing the error -  Error parsing PCC subspaces from PCCT 

Snippet of messages file: 


Mar 22 20:35:02 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 23 22:14:07 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 23 22:58:57 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 26 11:44:35 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 28 22:13:27 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 29 20:52:47 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)

Mar 31 21:26:09 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 31 21:26:09 charon kernel: Error parsing PCC subspaces from PCCT
Mar 31 21:31:04 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 31 21:31:04 charon kernel: Error parsing PCC subspaces from PCCT
Mar 31 22:23:37 charon kernel: ACPI: PCCT 0x00000000CCDDA000 00006E (v05 LENOVO TP-JB    00001210 PTEC 00000002)
Mar 31 22:23:37 charon kernel: Error parsing PCC subspaces from PCCT


from - /etc/grub2.cfg


menuentry 'Fedora (4.10.6-200.fc25.x86_64) 25 (Twenty Five)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.8.6-300.fc25.x86_64-advanced-b839301b-2a04-41e6-9dbb-58e664da359c' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  d9619e42-d07a-4a7c-a5e7-cdc88be3b7cc
        else
          search --no-floppy --fs-uuid --set=root d9619e42-d07a-4a7c-a5e7-cdc88be3b7cc
        fi
        linux16 /vmlinuz-4.10.6-200.fc25.x86_64 root=/dev/mapper/fedora_charon-root ro rd.lvm.lv=fedora_charon/root rd.luks.uuid=luks-812e33a4-42c1-43fa-b4a8-cd6494b6ccce rd.lvm.lv=fedora_charon/swap rhgb quiet LANG=en_GB.UTF-8
        initrd16 /initramfs-4.10.6-200.fc25.x86_64.img
}
menuentry 'Fedora (4.10.5-200.fc25.x86_64) 25 (Twenty Five)' --class fedora --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option 'gnulinux-4.8.6-300.fc25.x86_64-advanced-b839301b-2a04-41e6-9dbb-58e664da359c' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint='hd0,msdos1'  d9619e42-d07a-4a7c-a5e7-cdc88be3b7cc
        else
          search --no-floppy --fs-uuid --set=root d9619e42-d07a-4a7c-a5e7-cdc88be3b7cc
        fi
        linux16 /vmlinuz-4.10.5-200.fc25.x86_64 root=/dev/mapper/fedora_charon-root ro rd.lvm.lv=fedora_charon/root rd.luks.uuid=luks-812e33a4-42c1-43fa-b4a8-cd6494b6ccce rd.lvm.lv=fedora_charon/swap rhgb quiet LANG=en_GB.UTF-8
        initrd16 /initramfs-4.10.5-200.fc25.x86_64.img


Let me know what other diagnostic information is required.

Comment 4 Nick Cross 2017-04-04 13:18:18 UTC
I am seeing this as well on a W541. 

Kernel:
Linux atlantis 4.10.8-200.fc25.x86_64 #1 SMP Fri Mar 31 13:20:22 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Subsection from /boot/grub2/grub.cfg
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (4.10.8-200.fc25.x86_64) 25 (Twenty Five)' --class fedora --class gnu-linux --class gnu --class os --unrestricted
 $menuentry_id_option 'gnulinux-4.3.3-301.fc23.x86_64-advanced-e35c2184-ea11-4c2b-8b45-6dc977c42b97' {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_msdos
        insmod ext2
        set root='hd0,msdos1'
        if [ x$feature_platform_search_hint = xy ]; then
          search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint
='hd0,msdos1'  9ef7ffc6-8414-4907-a914-de90ef428b82
        else
          search --no-floppy --fs-uuid --set=root 9ef7ffc6-8414-4907-a914-de90ef428b82
        fi
        linux16 /vmlinuz-4.10.8-200.fc25.x86_64 root=/dev/mapper/fedora-root ro rd.lvm.lv=fedora/root rd.luks.uuid=luks-c660afad-e9
d3-42a4-b36b-4fa4d1376aae rd.lvm.lv=fedora/swap rd.driver.blacklist=nouveau rhgb quiet LANG=en_GB.UTF-8
        initrd16 /initramfs-4.10.8-200.fc25.x86_64.img
}

Comment 5 Gianfranco Cecconi 2017-04-04 20:54:41 UTC
Same issue here from at least 4.10.5, on Fedora 25 on a Lenovo T450s.

Comment 6 Bogdan V Grosu 2017-04-06 08:52:35 UTC
I get the same issue on Fedora 25, Lenovo X1 Carbon. 

Another day another bug... :)

Comment 7 Jiri Canderle 2017-04-10 06:21:58 UTC
I am seeing it on Lenovo x240 Fedora25:

[    0.000000] Linux version 4.10.8-200.fc25.x86_64 (mockbuild@bkernel02.phx2.fedoraproject.org) (gcc version 6.3.1 20161221 (Red Hat 6.3.1-1) (GCC) ) #1 SMP Fri Mar 31 13:20:22 UTC 2017
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-4.10.8-200.fc25.x86_64 root=/dev/mapper/fedora_dhcp--24--116-root ro rd.lvm.lv=fedora_dhcp-24-116/root rd.lvm.lv=fedora_dhcp-24-116/swap rd.luks.uuid=luks-05ce51f7-6d9b-489c-95ca-ba053ba06c58 rhgb quiet LANG=en_US.UTF-8 crashkernel=128M

[    0.243516] Error parsing PCC subspaces from PCCT

Comment 8 Justin M. Forbes 2017-04-11 14:44:42 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 25 kernel bugs.

Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 26, and are still experiencing this issue, please change the version to Fedora 26.

If you experience different issues, please open a new bug report for those.

Comment 9 Dimitris 2017-04-12 03:23:07 UTC
No change, still seeing this under 4.10.9-200.fc25.x86_64

Comment 10 Qiao Zhao 2017-04-12 14:11:09 UTC
Also see the same problem on my Lenovo X1 Carbon:
$ dmesg | grep Error
[    0.327807] Error parsing PCC subspaces from PCCT
$ sudo dmidecode -s bios-version
N14ET28W (1.06 )
$ uname -r
4.10.8-200.fc25.x86_64

Add me to cc list.

Comment 11 Jiri Canderle 2017-04-12 14:26:31 UTC
(In reply to Justin M. Forbes from comment #8)
> *********** MASS BUG UPDATE **************
> 
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 25 kernel bugs.
> 
> Fedora 25 has now been rebased to 4.10.9-200.fc25.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.
> 
> If you have moved on to Fedora 26, and are still experiencing this issue,
> please change the version to Fedora 26.
> 
> If you experience different issues, please open a new bug report for those.

I have updated to F26 and still experiencing this bug (plus others):
$ sudo dmidecode -s bios-version
GIET76WW (2.26 )
$ uname -r
4.11.0-0.rc5.git0.1.fc26.x86_64

[    0.000000] microcode: microcode updated early to revision 0x1f, date = 2016-04-01
[    0.000000] Linux version 4.11.0-0.rc5.git0.1.fc26.x86_64 (mockbuild@bkernel01.phx2.fedoraproject.org) (gcc version 7.0.1 20170309 (Red Hat 7.0.1-0.12) (GCC) ) #1 SMP Mon Apr 3 17:54:15 UTC 2017
[    0.000000] Command line: BOOT_IMAGE=/vmlinuz-4.11.0-0.rc5.git0.1.fc26.x86_64 root=/dev/mapper/fedora_dhcp--24--116-root ro rd.lvm.lv=fedora_dhcp-24-116/root rd.lvm.lv=fedora_dhcp-24-116/swap rd.luks.uuid=luks-05ce51f7-6d9b-489c-95ca-ba053ba06c58 rhgb quiet LANG=en_US.UTF-8 crashkernel=128M
[    0.000000] SMBIOS 2.7 present.
[    0.000000] DMI: LENOVO 20AMS22U0A/20AMS22U0A, BIOS GIET76WW (2.26 ) 08/27/2014
[    0.227216] Error parsing PCC subspaces from PCCT

Comment 12 Joël Wijngaarde 2017-04-20 11:51:33 UTC
Experience the same bug on Lenovo Carbon X1

$ uname -r
4.10.10-200.fc25.x86_64

Comment 13 Mathieu Bridon 2017-05-10 07:42:01 UTC
Seeing the same on F25:

$ uname -r
4.10.13-200.fc25.x86_64

Comment 14 Jiri Konecny 2017-05-22 07:22:45 UTC
The same problem on F25:

4.10.15-200.fc25.x86_64
Lenovo T540p

Only Fedora installed (without multiboot).

Comment 15 Stanislav Kontar 2017-06-02 15:34:08 UTC
Lenovo T440s.

~ $ uname -r
4.10.17-200.fc25.x86_64
~ $ sudo dmidecode -s bios-version
GJET82WW (2.32 )

Comment 16 Anthony Fairchild 2017-06-05 15:52:35 UTC
Same problem on ThinkPad X1 Carbon 2nd Gen.
~$: uname -r
4.10.17-200.fc25.x86_64
~$: sudo dmidecode -s bios-version
GRET50WW (1.27 )

Comment 17 Max Roeleveld 2017-06-14 05:42:28 UTC
Same problem on an Asus X555LJ (started around 4.10 for me as well):

# dmidecode -s bios-version && dmidecode -s bios-release-date 
X555LJ.504
08/04/2015
# uname -r
4.11.3-202.fc25.x86_64

Grepping for PCCT in the journal gives me
Error parsing PCC subspaces from PCCT
ACPI: PCCT 0x000000009B3AD300 00006E (v05 PcctTa PcctTabl 00001000 INTL 20120913)

This machine is not running dual boot with Windows, there is another partition which holds an old Fedora install. The machine has Intel + Nvidia graphics, I'm using the Negativo17 drivers for the Nvidia card.

Comment 18 Max Roeleveld 2017-06-14 05:46:45 UTC
Created attachment 1287515 [details]
Dump of dmesg which contains the PCCT error message

Comment 19 RyanEatsFish 2017-07-05 18:11:29 UTC
For me as well, started around 4.10

uname -r
4.11.7-200.fc25.x86_64

Product Name: 20E20010US
Version: ThinkPad W550s
Version: N11ET40W (1.16 )
Release Date: 10/27/2016
Firmware Revision: 1.8

Not sure if it's related, but the next line asks me to disable FADT in BIOS, so I'm off to try that.  I'll post if that helps.  There are other (possibly unrelated) errors as well, that just showed up in 4.11.6 I think...

journalctl -b
errors and the lines between them (if useful...)

Error parsing PCC subspaces from PCCT
ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
ACPI: bus type PCI registered
acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5
PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf8000000-0xfbffffff] (base 0xf8000000)
PCI: not using MMCONFIG
PCI: Using configuration type 1 for base access
HugeTLB registered 1 GB page size, pre-allocated 0 pages
HugeTLB registered 2 MB page size, pre-allocated 0 pages
ACPI: Added _OSI(Module Device)
ACPI: Added _OSI(Processor Device)
ACPI: Added _OSI(3.0 _SCP Extensions)
ACPI: Added _OSI(Processor Aggregator Device)
ACPI : EC: EC started
ACPI : EC: interrupt blocked
ACPI: \: Used as first EC
ACPI: \: GPE=0x25, EC_CMD/EC_SC=0x66, EC_DATA=0x62
ACPI: \: Used as boot ECDT EC to handle transactions
ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
ACPI Error: Needed type [Reference], found [Integer] ffff93f5017079d8 (20170119/exresop-103)
ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable] (20170119/
ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff93f5050ebdc0), AE_AML_OPERAND_TY
ACPI: Dynamic OEM Table Load:

Comment 20 Chris 2017-07-08 20:08:50 UTC
Is there anything new about this error? I have a thinkpad t450s and tried to boot Ubuntu 14.05, 16.04, 17.04 from live usb stick - the error always occured. I installed Windows 10 and updated the BIOS, the error is still there.

Comment 21 Chris 2017-07-08 20:09:18 UTC
Is there anything new about this error? I have a thinkpad t450s and tried to boot Ubuntu 14.05, 16.04, 17.04 from live usb stick - the error always occured. I installed Windows 10 and updated the BIOS, the error is still there.

Comment 22 Chris 2017-07-08 20:09:24 UTC
Is there anything new about this error? I have a thinkpad t450s and tried to boot Ubuntu 14.05, 16.04, 17.04 from live usb stick - the error always occured. I installed Windows 10 and updated the BIOS, the error is still there.

Comment 23 tony 2017-07-08 21:59:53 UTC
this error is never going to be fixed. Moved to KUbuntu 17.04 and it works flawlessly.

Comment 24 Chris 2017-07-10 15:40:52 UTC
(In reply to tony from comment #23)
> this error is never going to be fixed. Moved to KUbuntu 17.04 and it works
> flawlessly.

I tested Kubuntu 17.04 from live usb - the error "Error parsing PCC subspaces from PCCT" occured. In my opinion its a kernal problem and this should be fixed.

Comment 25 tony 2017-07-10 17:05:35 UTC
If you are still getting the same error and it's USB key, and you believe it should be fixed then you need to speak with the developers and request the fix. I cannot fix it.

Comment 26 Guido 2017-07-11 18:28:38 UTC
I have had this innocuous, but, annoying error on my Lenovo Thinkpad T540p for many months. It's still there with F26 freshly installed today. I boot UEFI only. The message appears just after the elilo load info. (I don't use grub!)

Comment 27 Matt 2017-07-15 09:54:58 UTC
I just upgraded my Asus X555L laptop to F26 and now get this message. I don't seem to experience any issues as a result, but it is annoying as it causes the scrolling boot text to be visible before the plymouth Fedora logo animation (which makes things look broken).

Any way to just disable this warning?

Comment 28 Kaan Cappon 2017-07-16 08:22:24 UTC
Same issue with my T450s after my upgrade towards Fedora 26: 4.11.9-300.fc26.x86_64
Does this problem come from the fast boot/EFI?

Comment 29 Sujith 2017-07-18 14:53:58 UTC
Not sure about Fedora but RHEL-7.x disables CONFIG_MAILBOX 
(Security reasons?)

I also checked the acpidump. The PCCT defines only a "Generic Communications Subspace" or Type-0 and not the other two types.
(Ref: http://elixir.free-electrons.com/linux/latest/source/include/acpi/actbl3.h#L481) 

Whereas the acpi_pcc_probe takes count of only these 2 missing/not-defined PCC subspace types.. I do not know much about this to comment on why this approach..

(Ref: http://elixir.free-electrons.com/linux/latest/source/drivers/mailbox/pcc.c#L448)

Would like to have someone explain why kernel does not consider type-0 in this driver.

Comment 30 Louis B 2017-07-19 18:30:16 UTC
Same issue on a Lenovo T450s 20BXCTO1WW with kernel 4.11.10-300.fc26.x86_64

Comment 31 techtonik 2017-08-05 08:18:27 UTC
Can anybody set Fedora 26 version for this?

Comment 32 Chaiwat Suttipongsakul 2017-08-07 01:32:25 UTC
I have this issue on ThinkPad X240 since F25 and also on F26, that including my vanilla kernel compiled from source. From the observations on my vanilla kernels, this problem started from kernel 4.10 and still exists on 4.11 and 4.12. Eventually I have to revert back to kernel 4.9.x which doesn't have this error.

Comment 33 Nick Cross 2017-08-25 12:41:38 UTC
I am still seeing this on F26.

Comment 34 Franco Geller 2017-09-15 04:36:28 UTC
I have this issue on fedora 25 since kernel 4.10.x. Already upgrade to fedora 26, currently running kernel 4.12.11-300.fc26.x86_64, but still have this issue. BTW, I rebuild the boot initramfs image to fix an another bug, but this one persist.

Additional info:

Machine is an ASUS ROG G551JW, booting in fast boot. No dual/multi-boot, just Fedora. Secure boot disabled.

# dmidecode -s bios-version && dmidecode -s bios-release-date
G551JW.209
03/04/2016

# uname -a
Linux rog 4.12.11-300.fc26.x86_64 #1 SMP Thu Sep 7 18:32:12 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

# cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.12.11-300.fc26.x86_64 root=/dev/mapper/korora_rog-root ro rd.lvm.lv=korora_rog/root rd.lvm.lv=korora_rog/swap nouveau.modeset=0 rd.driver.blacklist=nouveau rhgb quiet

Comment 35 Mcjarod 2017-09-17 19:29:50 UTC
I've the same problem with my ASUS N56J any one know how to fix? I've just Fedora 24.

# uname -a
Linux localhost 4.11.9-100.fc24.x86_64 #1 SMP Wed Jul 5 16:34:07 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Comment 36 DG 2017-09-30 17:19:17 UTC
I see the same problem on my t450s with a Fedora 26...


My messages read:

Error parsing PCC subspaces from PCCT
ACPI Error: Needed Type [Reference], found [Integer] fff9e29139babd0 (20170119/exresop-103)
ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [OpcodeName unavailable](20170119/dswexec-461)
ACPI Error:method parse/execution failed [\PR.CPU0._PDC] Method ffff9e29150eb0c8), AE_AML_OPERAND_TYPE (20170119/psparse-543

Coud anybody indicate whats the problem or workaround?

Comment 37 Franco Geller 2017-10-04 06:12:38 UTC
This is what I have researched so far.

The error is triggered by the kernel's mailbox mechanism "pcc.c", specified by ACPIv5.1, you can see it here:

https://github.com/torvalds/linux/blob/master/drivers/mailbox/pcc.c#L476

While reading the ACPI specification, i found this:

ACPI Specification: http://www.uefi.org/sites/default/files/resources/ACPI_5_0_Errata_B.pdf#G18.1372480

PCC stands for Platform Communications Channel, this is a generic mechanism for OSPM (Operating System-directed configuration and Power Management) to communicate with an entity in the BMC (Baseboard Management Controller).

PCC defines a new address space type which is implemented as one or more independent communications channels, or subspaces.

PCC Subspaces are described by the PCC Subspace structure in the PCCT table. The subspace ID of a PCC subspace is its index in the array of subspace structures, starting with subspace 0. All subspaces have a common header, followed by a set of type-specific fields.

The specification defines a Generic PCC Subspace Structure (aka the Generic Communications Subspace), subspace type 0. And warns that all other subspace types are reserved.

I do not quite understand what is happening, may be the PCCT Tables are corrupted.

Comment 38 Mcjarod 2017-10-16 16:55:36 UTC
in my case I made a sudo badblocks -v to all partitions and found that the disk had bad sectors. I had to make a backup and change it. even a fsck can be attempted.

Comment 39 Willem Fourie 2017-10-20 13:42:20 UTC
upgraded last week from Fedora 25 to 26 and still get the same issue as well. I use a DELL Latitude E7250 laptop and had the same problem on Fedora 25. Last night I ran the latest Kernel updates from Fedora but the same problems still occurs.

Comment 40 Matt 2017-10-28 11:04:44 UTC
Anyone know if this still happens with F27?

Comment 41 Willem Fourie 2017-10-28 11:27:54 UTC
Yes it is, I just upgraded yesterday and it still happens

Comment 42 Davide Maglio 2017-11-19 10:21:04 UTC
same issue for me on Thinkpad T450s and F26

[davidemaglio@thinkpad-t450s ~]$ uname -a
Linux thinkpad-t450s 4.13.12-200.fc26.x86_64 #1 SMP Wed Nov 8 16:47:26 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
[davidemaglio@thinkpad-t450s ~]$ sudo dmidecode -s bios-version && sudo dmidecode -s bios-release-date
JBET66WW (1.30 )
09/13/2017

Comment 43 lennart_reuther 2017-11-19 17:01:53 UTC
Same issue here, Fedora 27, Lenovo X250:

Linux 4.13.12-300.fc27.x86_64 #1 SMP Wed Nov 8 16:38:01 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

BIOS:

N10ET36W (1.15 )
06/19/2015

Comment 44 António Trota 2017-11-20 09:45:03 UTC
Same here: Fedora 27 and Thinkpad X1.
0.215530 Error parsing PCC subspaces from PCCT.
Is this critical?

Comment 45 rkosegi 2017-12-04 13:05:52 UTC
Same here.

cat /etc/redhat-release
Fedora release 27 (Twenty Seven)


sudo dmidecode --type 0

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: LENOVO
	Version: J7ET61WW (2.06 )
	Release Date: 03/03/2014
	Address: 0xE0000
	Runtime Size: 128 kB
	ROM Size: 4096 kB

sudo dmidecode --type 1

Handle 0x0001, DMI type 1, 27 bytes
System Information
	Manufacturer: LENOVO
	Product Name: 20278  
	Version: B5400

Comment 46 Gurenko Alex 2017-12-19 19:58:28 UTC
Same problem with fresh Fedora 27 installation on Lenovo X1 Carbon 3rd gen

dmidecode --type 0
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 2.7 present.

Handle 0x0031, DMI type 0, 24 bytes
BIOS Information
        Vendor: LENOVO
        Version: N14ET42W (1.20 )
        Release Date: 09/13/2017
        Address: 0xE0000
        Runtime Size: 128 kB
        ROM Size: 16 MB
        Characteristics:
                PCI is supported
                PNP is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 1.20
        Firmware Revision: 1.9

Comment 47 Franco Geller 2017-12-20 02:36:08 UTC
(In reply to António Trota from comment #44)
> Same here: Fedora 27 and Thinkpad X1.
> 0.215530 Error parsing PCC subspaces from PCCT.
> Is this critical?

It's not critical, but it may become one. The bug is triggered by the kernel's mailbox mechanism pcc.c, specified by the ACPI specification. The PCC Subspaces are described by the PCC Subspace structure in the PCCT table. I think that the problem is on the PCCT table.

Here is more info:
https://firmware.intel.com/sites/default/files/resources/PCC%20White%20Paper_0.pdf

Comment 48 Prarit Bhargava 2018-01-11 18:38:49 UTC
(In reply to Franco Geller from comment #47)
> (In reply to António Trota from comment #44)
> > Same here: Fedora 27 and Thinkpad X1.
> > 0.215530 Error parsing PCC subspaces from PCCT.
> > Is this critical?
> 
> It's not critical, but it may become one. The bug is triggered by the
> kernel's mailbox mechanism pcc.c, specified by the ACPI specification. The
> PCC Subspaces are described by the PCC Subspace structure in the PCCT table.
> I think that the problem is on the PCCT table.
> 
> Here is more info:
> https://firmware.intel.com/sites/default/files/resources/
> PCC%20White%20Paper_0.pdf

The issue is that the PCC table says it exists but has no entries.  It's sort of like the BIOS/ACPI is saying "Here!  Have one of my zero apples!".

This is AFAICT a vendor bug and not necessarily a kernel bug.  I'll reach out to Intel on this one...

P.

Comment 50 David Ward 2018-01-15 02:02:00 UTC
Please change version to Fedora 27.

Appears on a Dell Latitude 7350. I have found that this model has extremely similar hardware (and therefore is affected by the same issues) as the Dell XPS 13 9343, mentioned in comment #1.

Comment 51 Steffen Weber 2018-01-29 12:10:44 UTC
I'm seeing this error with Linux 4.10..4.15 on HPE ProLiant DL360 Gen10 servers. The error is triggered because of sum == 0 (i.e. not because of sum >= MAX_PCC_SUBSPACES).

HPE denies support, claiming that this is a "non-ciritcal issue".

# dmidecode --type 0
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.1 present.

Handle 0x0003, DMI type 0, 26 bytes
BIOS Information
	Vendor: HPE
	Version: U32
	Release Date: 12/11/2017
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 64 MB
	Characteristics:
		PCI is supported
		PNP is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		ESCD support is available
		Boot from CD is supported
		Selectable boot is supported
		EDD is supported
		5.25"/360 kB floppy services are supported (int 13h)
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 kB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		CGA/mono video services are supported (int 10h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Function key-initiated network boot is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 1.28
	Firmware Revision: 1.17

Comment 52 Romualdas Mincevicius 2018-02-05 21:48:01 UTC
Hi!

Same boot error on my ThinkPad 450s with Arch Linux. If I recall it correctly this error appeared since linux 4.10 series.

Taking in to account what Prarit Bhargava wrote in comment #48 I made use of GRUB feature which gives an option to disable given ACPI table (https://www.gnu.org/software/grub/manual/grub/grub.html#acpi).
Specifically I modified my GRUB config file to give me optional GRUB boot menu option with PCCT table disabled by including additional command:

acpi -x PCCT

This is not a real solution, but I recon if the table does not function anyway it may as well be completely disabled, which gives me a clean boot message log.

I have been running for a while with in such a way disabled PCCT table without noticing any adverse effects but as always YMMW.

Comment 53 Franco Geller 2018-02-06 05:44:01 UTC
(In reply to Romualdas Mincevicius from comment #52)
> Hi!
> 
> Same boot error on my ThinkPad 450s with Arch Linux. If I recall it
> correctly this error appeared since linux 4.10 series.
> 
> Taking in to account what Prarit Bhargava wrote in comment #48 I made use of
> GRUB feature which gives an option to disable given ACPI table
> (https://www.gnu.org/software/grub/manual/grub/grub.html#acpi).
> Specifically I modified my GRUB config file to give me optional GRUB boot
> menu option with PCCT table disabled by including additional command:
> 
> acpi -x PCCT
> 
> This is not a real solution, but I recon if the table does not function
> anyway it may as well be completely disabled, which gives me a clean boot
> message log.
> 
> I have been running for a while with in such a way disabled PCCT table
> without noticing any adverse effects but as always YMMW.

This has not worked for me. The error keeps coming up and throw some new errors. Any idea why?

Comment 54 Knut J BJuland 2018-02-06 09:42:44 UTC
I have the same problem with msi sli plus x299.

knutjb@knut:~$ sudo dmidecode --type 0
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.0 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
	Vendor: American Megatrends Inc.
	Version: 1.70
	Release Date: 11/29/2017
	Address: 0xF0000
	Runtime Size: 64 kB
	ROM Size: 16 MB
	Characteristics:
		PCI is supported
		BIOS is upgradeable
		BIOS shadowing is allowed
		Boot from CD is supported
		Selectable boot is supported
		BIOS ROM is socketed
		EDD is supported
		5.25"/1.2 MB floppy services are supported (int 13h)
		3.5"/720 kB floppy services are supported (int 13h)
		3.5"/2.88 MB floppy services are supported (int 13h)
		Print screen service is supported (int 5h)
		8042 keyboard services are supported (int 9h)
		Serial services are supported (int 14h)
		Printer services are supported (int 17h)
		ACPI is supported
		USB legacy is supported
		BIOS boot specification is supported
		Targeted content distribution is supported
		UEFI is supported
	BIOS Revision: 5.13

Comment 55 Aleksei Kovura 2018-02-15 06:37:37 UTC
Same error here on Dell E5450.

# dmidecode --type 0
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 2.8 present.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: Dell Inc.
        Version: A15
        Release Date: 05/09/2017
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 12288 kB
        Characteristics:                                                                                                                                                                     
                PCI is supported                                                                                                                                                             
                PNP is supported                                                                                                                                                             
                BIOS is upgradeable                                                                                                                                                          
                BIOS shadowing is allowed                                                                                                                                                    
                Boot from CD is supported                                                                                                                                                    
                Selectable boot is supported                                                                                                                                                 
                EDD is supported                                                                                                                                                             
                5.25"/1.2 MB floppy services are supported (int 13h)                                                                                                                         
                3.5"/720 kB floppy services are supported (int 13h)                                                                                                                          
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                Smart battery is supported
                BIOS boot specification is supported
                Function key-initiated network boot is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 65.15

Comment 56 Gurenko Alex 2018-02-21 08:09:03 UTC
Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel

Comment 57 Aleksei Kovura 2018-02-21 09:29:39 UTC
(In reply to Gurenko Alex from comment #56)
> Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel

Was there a downstream fix in Fedora? I'm still getting this on 4.15.3 kernel on Arch.

Comment 58 Gurenko Alex 2018-02-21 10:39:49 UTC
(In reply to Aleksei Kovura from comment #57)
> (In reply to Gurenko Alex from comment #56)
> > Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel
> 
> Was there a downstream fix in Fedora? I'm still getting this on 4.15.3
> kernel on Arch.

 Not that I know of, but after following comment [https://bugzilla.redhat.com/show_bug.cgi?id=1458390#c13]  I went over issues I had on my Lenovo T460p and these two issues are gone for me. Have not checked on my Ryzen build at home yet.

Comment 59 Aleksei Kovura 2018-02-21 10:49:06 UTC
(In reply to Gurenko Alex from comment #58)
> (In reply to Aleksei Kovura from comment #57)
> > (In reply to Gurenko Alex from comment #56)
> > > Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel
> > 
> > Was there a downstream fix in Fedora? I'm still getting this on 4.15.3
> > kernel on Arch.
> 
>  Not that I know of, but after following comment
> [https://bugzilla.redhat.com/show_bug.cgi?id=1458390#c13]  I went over
> issues I had on my Lenovo T460p and these two issues are gone for me. Have
> not checked on my Ryzen build at home yet.

The comment you linked is just "we are sorry for inconvenience", and there are no solutions/workarounds in the rest of 1458390, and 1458390 doesn't seem related to this. Care to clarify?

Comment 60 Gurenko Alex 2018-02-21 10:56:31 UTC
(In reply to Aleksei Kovura from comment #59)
> (In reply to Gurenko Alex from comment #58)
> > (In reply to Aleksei Kovura from comment #57)
> > > (In reply to Gurenko Alex from comment #56)
> > > > Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel
> > > 
> > > Was there a downstream fix in Fedora? I'm still getting this on 4.15.3
> > > kernel on Arch.
> > 
> >  Not that I know of, but after following comment
> > [https://bugzilla.redhat.com/show_bug.cgi?id=1458390#c13]  I went over
> > issues I had on my Lenovo T460p and these two issues are gone for me. Have
> > not checked on my Ryzen build at home yet.
> 
> The comment you linked is just "we are sorry for inconvenience", and there
> are no solutions/workarounds in the rest of 1458390, and 1458390 doesn't
> seem related to this. Care to clarify?

 Yes, I'm referring to this part in particular "As kernel maintainers, we try to keep up with bugzilla but due the rate at which the upstream kernel project moves, bugs may be fixed without any indication to us".
 Since you're experiencing same problem on Arch as here in Fedora, meaning it probably has an upstream BZ? So there is a possibility it's fixed and kernel rebase fixed at least it for someone.

Comment 61 Laura Abbott 2018-03-16 21:44:20 UTC
*** Bug 1468315 has been marked as a duplicate of this bug. ***

Comment 62 Knut J BJuland 2018-03-17 08:24:08 UTC
dmidecode -s bios-version && dmidecode -s bios-release-date
1.80
01/31/2018
# dmidecode 3.1
Getting SMBIOS data from sysfs.
SMBIOS 3.0 present.
89 structures occupying 3901 bytes.
Table at 0x4F936000.

Handle 0x0000, DMI type 0, 24 bytes
BIOS Information
        Vendor: American Megatrends Inc.
        Version: 1.80
        Release Date: 01/31/2018
        Address: 0xF0000
        Runtime Size: 64 kB
        ROM Size: 16 MB
        Characteristics:
                PCI is supported
                BIOS is upgradeable
                BIOS shadowing is allowed
                Boot from CD is supported
                Selectable boot is supported
                BIOS ROM is socketed
                EDD is supported
                5.25"/1.2 MB floppy services are supported (int 13h)
                3.5"/720 kB floppy services are supported (int 13h)
                3.5"/2.88 MB floppy services are supported (int 13h)
                Print screen service is supported (int 5h)
                8042 keyboard services are supported (int 9h)
                Serial services are supported (int 14h)
                Printer services are supported (int 17h)
                ACPI is supported
                USB legacy is supported
                BIOS boot specification is supported
                Targeted content distribution is supported
                UEFI is supported
        BIOS Revision: 5.13
X299 SLI PLUS (MS-7A93)

I have MSI x299 SLI plus motherboard.

Comment 63 Gianfranco Cecconi 2018-03-17 09:11:00 UTC
(In reply to Aleksei Kovura from comment #57)
> (In reply to Gurenko Alex from comment #56)
> > Seems to be fixed with 4.15.3-300.fc27.x86_64 kernel
> 
> Was there a downstream fix in Fedora? I'm still getting this on 4.15.3
> kernel on Arch.

I am still getting this, too, with 4.15.9 on Fedora running on a Lenovo T450s, in case it was useful.

Comment 64 Al Stone 2018-03-19 20:46:10 UTC
The dmidecode output is interesting, but not terribly useful for this bug.  Could someone post the FADT (file name is FACP) and PCCT from one of the systems with an error (they should be in /sys/firmware/acpi/tables)?  With both of these tables, it's pretty straightforward to see if there is really a problem or not.

The message is showing up because the code that loads the PCCT is looking for two specific types of subtables within the PCCT -- types 1 and 2.  There are five possible types, however.  Types 1 and 2 are to be used on ACPI "hardware reduced" platforms; they were added for use on aarch64, originally, and may show up on others in the future.  However, x86_64 systems are not typically "hardware reduced" and may have only type 0, 3 or 4 subtables in their PCCT, if they have one at all.

What the kernel is saying is:

   if no type 1 or 2 subtables are in the PCCT,
      error condition
   endif

What the kernel _should be_ saying (imho) is:

   if the "hardware reduced" flag is set in the FADT,
      if no type 1 or type 2 subtables in the PCCT,
         error: PCC mailboxes will not work
      endif
   else
      if no type 0, 3 or 4 subtables in the PCCT,
         error: PCC mailboxes will not work
      endif
   endif

At a minimum, the message is not really accurate.  At best, it is misleading.  Regardless, it is unlikely a problem, especially on laptops -- the PCCT is supposed to be used to describe how the CPU communicates with a BMC on a server machine.

Comment 65 Knut J BJuland 2018-03-20 05:56:23 UTC
FACP<F4>^@^@^@^FTKmpletKomplett  ^G^AAMI ^S^@^A^@<80>p^AN<80><F2> M^@^A ^@<B2>^@^@^@<A0><A1>^@^@
^@^X^@^@^@^@^@^@^D^X^@^@^@^@^@^@P^X^@^@^H^X^@^@<80>^X^@^@^@^@^@^@^D^B^A^D ^@^@^@e^@<E9>^C^@^D^P^@^@^@^M^@2^@^@^@<A5><84>^C^@^A^H^@^@<F9>^L^@^@^@^@^@^@^F^@^@^@^@^@^@^@^@^@^@^@<80><F2> M^@^@^@^@^A ^@^B^@^X^@^@^@^@^@^@^A^@^@^B^@^@^@^@^@^@^@^@^A^P^@^B^D^X^@^@^@^@^@^@^A^@^@^B^@^@^@^@^@^@^@^@^A^H^@^AP^X^@^@^@^@^@^@^A ^@^C^H^X^@^@^@^@^@^@^A<80>^@^A<80>^X^@^@^@^@^@^@^A^@^@^A^@^@^@^@^@^@^@^@
FACP (END)

and

PCCTn^@^@^@^A<9E>ALASKAA M I ^@^@^B^@^@^@INTL^S^P        ^A^@^@^@^@^@^@^@^@^@^@^@^@>^@^@^@^@^@^@
^Xq^AN^@^@^@^@<88>^H^@^@^@^@^@^@^A^H^@^A<B2>^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@<FD>^@^@^@^@^@^@^@^@^@
^@^@^@^@^@^@^@^@
PCCT (END)


I have post both FACP and PCCT from /sys/firmware/acpi/tables

Comment 66 Aleksei Kovura 2018-03-20 09:45:43 UTC
Created attachment 1410351 [details]
/sys/firmware/acpi/tables/PCCT from a Dell laptop

Comment 67 Aleksei Kovura 2018-03-20 09:46:54 UTC
Created attachment 1410352 [details]
/sys/firmware/acpi/tables/FACP from a Dell laptop

Comment 68 Aleksei Kovura 2018-03-20 09:48:31 UTC
(In reply to Al Stone from comment #64)
> Could someone post the FADT (file name is FACP) and PCCT from one of the
> systems with an error (they should be in /sys/firmware/acpi/tables)?  With
> both of these tables, it's pretty straightforward to see if there is really
> a problem or not.
Posted.

Comment 69 Romualdas Mincevicius 2018-03-20 19:51:57 UTC
Created attachment 1410772 [details]
FADT and PCCT tables for ThinkPad T450s

(In reply to Al Stone from comment #64)
> Could someone post the FADT (file name is FACP) and PCCT from one of the
> systems with an error (they should be in /sys/firmware/acpi/tables)?  With
> both of these tables, it's pretty straightforward to see if there is really
> a problem or not.

Attached the tables for ThinkPad T450s.

Comment 70 Ming Lei 2018-03-27 09:50:48 UTC
(In reply to Steffen Weber from comment #51)
> I'm seeing this error with Linux 4.10..4.15 on HPE ProLiant DL360 Gen10
> servers. The error is triggered because of sum == 0 (i.e. not because of sum
> >= MAX_PCC_SUBSPACES).

I see this error with Fedora 27(4.13.9-300.fc27.x86_64) on HPE DL380 Gen10 too.

Comment 71 Franco Geller 2018-03-28 02:21:20 UTC
Created attachment 1413946 [details]
/sys/firmware/acpi/tables/FACP from an ASUS ROG G551JW

(In reply to Al Stone from comment #64)

/sys/firmware/acpi/tables/FACP from an ASUS ROG G551JW

Booting in fast boot. No dual/multi-boot, just Fedora. Secure boot disabled.

# dmidecode -s bios-version && dmidecode -s bios-release-date
G551JW.209
03/04/2016

# uname -a
Linux rog 4.15.9-200.fc26.x86_64 #1 SMP Mon Mar 12 17:11:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 72 Franco Geller 2018-03-28 02:23:15 UTC
Created attachment 1413947 [details]
/sys/firmware/acpi/tables/PCCT from an ASUS ROG G551JW

(In reply to Al Stone from comment #64)

/sys/firmware/acpi/tables/PCCT from an ASUS ROG G551JW

Booting in fast boot. No dual/multi-boot, just Fedora. Secure boot disabled.

# dmidecode -s bios-version && dmidecode -s bios-release-date
G551JW.209
03/04/2016

# uname -a
Linux rog 4.15.9-200.fc26.x86_64 #1 SMP Mon Mar 12 17:11:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Comment 73 Al Stone 2018-04-04 21:17:17 UTC
I'm attaching the patches I've sent upstream; they're on the linux-acpi and linux-kernel mailing lists.  Here's the linux-acpi link:

   https://www.spinics.net/lists/linux-acpi/msg81559.html

Thanks to everyone that posted a copy of their PCCT.  As I suspected, none of them are actually in error.  What was happening was that acpi_pcc_probe() was reading the PCCT and making assumptions about the mailboxes being defined -- specifically, that only arm64-specific mailboxes would be in the PCCT.  If no such mailboxes are found, the probe function prints the error message we see, regardless of whether or not there are any additional mailboxes defined.  In all of the cases posted -- and on my laptop -- there is a generic mailbox defined properly.  So, the error is incorrect in this case, and ignoring a request to set up a perfectly normal PCC mailbox.  The patches cause acpi_pcc_probe() to look for any valid mailbox definition and then create whatever has been requested.

To be fair, I do not know why a PCC mailbox is needed on a laptop -- sensor communications, perhaps?  They are typically used as a path to BMCs on servers.  When mine is enabled, though, everything continues to operate as it had before, minus the annoying error message.

Please build test kernels with these patches and let me know if there are any problems.

Comment 74 Al Stone 2018-04-04 21:19:06 UTC
Created attachment 1417469 [details]
patch 1/3 -- simple documentation fix only

applies to linux-next tree

Comment 75 Al Stone 2018-04-04 21:20:19 UTC
Created attachment 1417475 [details]
patch 2/3 -- fix a possible subtable parsing issue

applies to linux-next

Comment 76 Al Stone 2018-04-04 21:21:25 UTC
Created attachment 1417476 [details]
patch 3/3 -- correct bogus error message about PCCT

applies to linux-next

Comment 77 Dominik 'Rathann' Mierzejewski 2018-04-23 06:09:39 UTC
Created attachment 1425543 [details]
FACP from Sony Vaio Pro 13

Comment 78 Dominik 'Rathann' Mierzejewski 2018-04-23 06:11:25 UTC
Created attachment 1425544 [details]
PCCT from Sony Vaio Pro 13

Comment 79 Dominik 'Rathann' Mierzejewski 2018-04-23 06:15:36 UTC
Still occurring with kernel-4.16.3-200.fc27.x86_64.

Comment 80 Al Stone 2018-04-23 22:22:03 UTC
(In reply to Dominik 'Rathann' Mierzejewski from comment #79)
> Still occurring with kernel-4.16.3-200.fc27.x86_64.

Upstream still has not approved the fix, so the patches have not been pulled into the kernel yet.

Comment 81 Al Stone 2018-04-24 20:11:15 UTC
Version 2 of patches posted:

   https://www.spinics.net/lists/linux-acpi/msg81863.html

Comment 82 Al Stone 2018-05-24 17:41:52 UTC
Created attachment 1441175 [details]
Upstream patch (as accepted in linux-pm)

This file is a patch against the Fedora kernel tree that includes a copy of the upstream patch that removes this error.  At some point, probably 4.18 or later, this will be included and does not need to be a separate patch.

Comment 83 Jeremy Cline 2018-05-25 15:10:16 UTC
Thanks, I've applied it so it should be included in the next Rawhide build and the v4.16.12 builds for stable.

Comment 84 Al Stone 2018-05-25 20:28:51 UTC
(In reply to Jeremy Cline from comment #83)
> Thanks, I've applied it so it should be included in the next Rawhide build
> and the v4.16.12 builds for stable.

Thanks!

Comment 85 Fedora Update System 2018-05-26 15:38:16 UTC
kernel-4.16.12-300.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-537c8312fc

Comment 86 Fedora Update System 2018-05-26 15:39:17 UTC
kernel-4.16.12-200.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9d0e4e40b5

Comment 87 Fedora Update System 2018-05-26 20:37:06 UTC
kernel-4.16.12-200.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9d0e4e40b5

Comment 88 Fedora Update System 2018-05-26 23:31:12 UTC
kernel-4.16.12-300.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-537c8312fc

Comment 89 Fedora Update System 2018-05-29 11:20:09 UTC
kernel-4.16.12-300.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 90 Fedora Update System 2018-05-29 11:49:48 UTC
kernel-4.16.12-200.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 91 Leo 2018-06-05 15:08:34 UTC
My system: Linux 4.16.7-200.fc27.x86_64

That message ("Error parsing PCC subspaces from PCCT") still persists, but to be honest I don't know whether that error is because of something that is relevant or not. I'm just letting you know, guys.

Cheers.

Comment 92 Leo 2018-06-05 15:12:04 UTC
My system: Linux 4.16.7-200.fc27.x86_64

That message ("Error parsing PCC subspaces from PCCT") still persists, but to be honest I don't know whether that error is because of something that is relevant or not. I'm just letting you know, guys.

The following commands:

    dmidecode -s bios-version && dmidecode -s bios-release-date

Give me:

    X555LAB.503
    08/04/2015



Cheers.

Comment 93 Al Stone 2018-06-05 16:24:02 UTC
(In reply to Leo from comment #91)
> My system: Linux 4.16.7-200.fc27.x86_64
> 
> That message ("Error parsing PCC subspaces from PCCT") still persists, but
> to be honest I don't know whether that error is because of something that is
> relevant or not. I'm just letting you know, guys.
> 
> Cheers.

Looks like that's an older kernel; the fix should be in kernel-4.16.12-200.fc27.
Could you try that, please?  If you still get the message, please send me a copy of the PCCT file from /sys/firmware/acpi/tables and I'll look into it.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.