Bug 143586 - MC is frozen when transfer abort under FISH vfs
MC is frozen when transfer abort under FISH vfs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
: EasyFix, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 11:29 EST by Dmitry Butskoy
Modified: 2013-07-02 19:04 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-02 09:21:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The patch for this issue (548 bytes, patch)
2004-12-22 11:34 EST, Dmitry Butskoy
no flags Details | Diff

  None (edit)
Description Dmitry Butskoy 2004-12-22 11:29:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3)
Gecko/20040923

Description of problem:
 FISH vfs freezes MC on transfer abort.

Version-Release number of selected component (if applicable):
mc-4.6.1a-0.3

How reproducible:
Always

Steps to Reproduce:
1. Login as unprivileged user, run mc
2. Set on the one panel any local directory where you have no write access
3. On the other panel, cd somewhere using FISH (cd /#sh: ... )
4. Try to copy some file from remote system to local dir

    

Actual Results:    Because of missing write access, MC report error
and then starts to abort transfer. But never finishes it...

Additional info:

 This issue is inspired by the trivial bug -- see the patch below.
Instead of flush of the same amount of bytes as the non-transferred
file is, everything is flushed, including special FISH`s exit codes etc.
Comment 1 Dmitry Butskoy 2004-12-22 11:34:29 EST
Created attachment 109027 [details]
The patch for this issue

  This patch has been sent to upstream more than month back, but is not applied
yet...
Comment 2 Leonard den Ottolander 2004-12-23 07:50:19 EST
Dmitry, please resubmit upstream. Development has died down a bit, but
I believe this only to be temporary. As developers are sometimes busy
with other things you might have to draw their attention another time.
Patience is a virtue ;) .

In the mean time I will add some of the known issues on the TODO wiki
at http://pavelsh.pp.ru/wiki/doku.php?id=mc-bugs . It might take a few
days before your bug shows up here.
Comment 3 Leonard den Ottolander 2004-12-28 16:39:46 EST
Patch was committed upstream.
Comment 4 Leonard den Ottolander 2004-12-29 12:29:57 EST
Dmitry, could you please stop faqing around with bugzilla?

If this bug was supposed to be closed I would have done so.

Resolution UPSTREAM is for bugs that need to be handled upstream and
will not be touched by the downstream maintainer, not bugs that are
fixed upstream. Sometimes a backport is necessary instead of an
updated tarball, so this issue has not been resolved here (downstream)
yet.

Comment 5 Jindrich Novy 2005-02-02 09:21:30 EST
The new mc-4.6.1a-0.4 is just built. It reflects your fixes now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.