Bug 1435974 - neutron_lbaas.tests.tempest.v2.scenario tests failed cause mismatch between lbaas & tempest rpm
Summary: neutron_lbaas.tests.tempest.v2.scenario tests failed cause mismatch between l...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron-lbaas
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Nir Magnezi
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-26 11:27 UTC by Eran Kuris
Modified: 2017-05-17 20:13 UTC (History)
10 users (show)

Fixed In Version: openstack-neutron-lbaas-10.0.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:13:35 UTC


Attachments (Terms of Use)
log (14.62 KB, text/plain)
2017-03-26 11:27 UTC, Eran Kuris
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 450447 None None None 2017-03-29 18:55:28 UTC

Description Eran Kuris 2017-03-26 11:27:50 UTC
Created attachment 1266508 [details]
log

Description of problem:
All neutron_lbaas.tests.tempest.v2.scenario tests failed :
neutron_lbaas.tests.tempest.v2.scenario.test_listener_basic.TestListenerBasic.test_listener_basic[compute,network]
neutron_lbaas.tests.tempest.v2.scenario.test_healthmonitor_basic.TestHealthMonitorBasic.test_health_monitor_basic[compute,network]
neutron_lbaas.tests.tempest.v2.scenario.test_shared_pools.TestSharedPools.test_shared_pools[compute,network]
neutron_lbaas.tests.tempest.v2.scenario.test_load_balancer_basic.TestLoadBalancerBasic.test_load_balancer_basic[compute,network]
neutron_lbaas.tests.tempest.v2.scenario.test_session_persistence.TestSessionPersistence.test_session_persistence[compute,network]


Cause mismatch between lbaas & tempest rpm
 

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/neutron_lbaas/tests/tempest/v2/scenario/base.py", line 84, in setUp
    self._set_net_and_subnet()
  File "/usr/lib/python2.7/site-packages/neutron_lbaas/tests/tempest/v2/scenario/base.py", line 122, in _set_net_and_subnet
    tenant_net = self._list_networks(tenant_id=tenant_id)[0]
AttributeError: 'TestHealthMonitorBasic' object has no attribute '_list_networks'


Version-Release number of selected component (if applicable):
ocata- osp-11
python-tempestconf-1.0.0-2.el7ost.noarch
puppet-tempest-10.3.0-2.el7ost.noarch
python-tempest-15.0.0-1.el7ost.noarch
openstack-tempest-15.0.0-1.el7ost.noarch
python-neutron-lbaas-tests-10.0.0-3.el7ost.noarch



in previous version it worked : 
python-tempestconf-1.0.1-0.20170310150049.feaf377.el7ost.noarch
puppet-tempest-10.3.0-0.20170210202111.47a23ee.el7ost.noarch
python-tempest-15.0.0-1.el7ost.noarch
openstack-tempest-15.0.0-1.el7ost.noarch
python-neutron-lbaas-tests-10.0.0-2.el7ost.noarch
How reproducible:
always

Steps to Reproduce:
1.Run our CI job : https://rhos-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/job/qe-DFG-neutron-11_director-rhel-7.3-virthost-1cont_2comp-ipv4-vxlan-lvm-lbaas/12
2.
3.

Actual results:
tests failed 

Expected results:
tests will pass 

Additional info:

Comment 5 Martin Kopec 2017-03-28 23:20:16 UTC
There were some changes in neutron-lbaas package, for example:
https://github.com/openstack/neutron-lbaas/blob/master/neutron_lbaas/tests/tempest/v2/scenario/base.py#L122
and
https://github.com/openstack/neutron-lbaas/blob/stable/ocata/neutron_lbaas/tests/tempest/v2/scenario/base.py#L122

With older neutron-lbaas package (python-neutron-lbaas-tests-10.0.0-2.el7ost.noarch) tests pass. 
According to testing, it's needed to create a new neutron-lbaas package, so I'm changing the component name to openstack-neutron-lbaas.

Comment 9 Assaf Muller 2017-03-29 18:55:28 UTC
It turns out the upsteam stable/ocata branch of neutron-lbaas API tests are broken. Ihar identified this and backported the fix:

https://review.openstack.org/#/c/450447/

Nir, if you can please make sure this is merged in to our OSP 11 branch.

Comment 10 Nir Magnezi 2017-03-29 21:08:00 UTC
(In reply to Assaf Muller from comment #9)
> It turns out the upsteam stable/ocata branch of neutron-lbaas API tests are
> broken. Ihar identified this and backported the fix:
> 
> https://review.openstack.org/#/c/450447/
> 
> Nir, if you can please make sure this is merged in to our OSP 11 branch.

Done. will merge and build a package after reviews

Comment 13 Eran Kuris 2017-04-04 19:12:14 UTC
Fix verified
openstack-neutron-lbaas-10.0.0-5.el7ost.noarch
OSP-11

Comment 15 errata-xmlrpc 2017-05-17 20:13:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.