Bug 1436021 - Restarting openvswitch triggers neutron-openvswitch-agent to start
Summary: Restarting openvswitch triggers neutron-openvswitch-agent to start
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemd
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: pre-dev-freeze
: 7.3
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
Depends On:
Blocks: 1414325 1443992
TreeView+ depends on / blocked
 
Reported: 2017-03-26 20:06 UTC by Tim Rozet
Modified: 2017-08-01 09:14 UTC (History)
16 users (show)

Fixed In Version: systemd-219-37.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1443992 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:14:52 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2297 normal SHIPPED_LIVE systemd bug fix and enhancement update 2017-08-01 12:40:16 UTC
RDO 5951 None None None 2017-03-27 12:31:03 UTC
Launchpad 1671504 None None None 2017-04-11 14:52:19 UTC

Description Tim Rozet 2017-03-26 20:06:10 UTC
Description of problem:
When running a tripleo deployment without neutron-openvswitch-agent enabled, if openvswitch is ever restarted, it triggers neutron-openvswitch-agent to start.

Version-Release number of selected component (if applicable):
Newton

How reproducible:
Everytime

Steps to Reproduce:
1. Disable neutron-openvswitch-agent from compute and control profiles in tripleO:
resource_registry:
  OS::TripleO::Services::NeutronOvsAgent: OS::Heat::None
  OS::TripleO::Services::ComputeNeutronOvsAgent: OS::Heat::None
2. Deploy.
3. Login to a compute node
4. systemctl restart openvswitch


Actual results:
 neutron-openvswitch-agent will also start

Expected results:
 neutron-openvswitch-agent should not start

Additional info:

Comment 3 Jakub Libosvar 2017-04-11 15:45:00 UTC
This is a bug in systemd fixed in upstream. Switching component.

Comment 5 Assaf Muller 2017-04-11 16:04:32 UTC
Note that this systemd issue has been affecting OpenStack since the OSP 5 release where we started using systemd on RHEL 7. This is not a regression in OSP 11.

Comment 6 Jan Synacek 2017-04-12 06:31:59 UTC
(In reply to Jakub Libosvar from comment #3)
> This is a bug in systemd fixed in upstream.

Where?

Comment 7 Jakub Libosvar 2017-04-12 07:14:16 UTC
(In reply to Jan Synacek from comment #6)
> (In reply to Jakub Libosvar from comment #3)
> > This is a bug in systemd fixed in upstream.
> 
> Where?

Forwarding needinfo to Michal as he's the one who found the patch.

Comment 19 errata-xmlrpc 2017-08-01 09:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2297


Note You need to log in before you can comment on or make changes to this bug.