Bug 143604 - wnck-applet doesn't list windows on other Xinerama screens
wnck-applet doesn't list windows on other Xinerama screens
Status: CLOSED DUPLICATE of bug 138874
Product: Fedora
Classification: Fedora
Component: gnome-panel (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 14:56 EST by Bryan O'Sullivan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryan O'Sullivan 2004-12-22 14:56:11 EST
Description of problem:

The GNOME window list applet, which I assume is wnck-applet, doesn't
work properly with Xinerama displays.

I have a dual-head system.  Whichever Xinerama screen the GNOME panel
 is displaying on, wnck-applet fails to display any windows from the
other Xinerama screen.

If I move the GNOME panel from one screen to the other, the list of
windows showing up in wnck-applet's list changes so that only the
windows on the new screen appear.

The criterion for whether a window is "on" a particular screen seems
to be whether the midpoint of the window is on that screen or not.

Version-Release number of selected component (if applicable):

gnome-panel-2.8.1-3

How reproducible:

100%

Steps to Reproduce:
1. Set up a multihead system.
2. Run GNOME.  Create windows on each screen.
3. Look at wnck-applet.  Notice that only windows on one screen
populate the window list.
  
Expected results:

I'd expect all windows to show up.
Comment 1 Mark McLoughlin 2005-01-05 05:40:24 EST

*** This bug has been marked as a duplicate of 138874 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.