Bug 1436061 - initscripts 9.03.58-1.el6 breaks gre interfaces
Summary: initscripts 9.03.58-1.el6 breaks gre interfaces
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: initscripts
Version: 6.9
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Daniel Rusek
Petr Bokoc
URL:
Whiteboard:
Depends On:
Blocks: 1374441 1441289
TreeView+ depends on / blocked
 
Reported: 2017-03-27 04:36 UTC by Dmitry Melekhov
Modified: 2018-06-19 05:21 UTC (History)
12 users (show)

Fixed In Version: initscripts-9.03.59-1.el6
Doc Type: Bug Fix
Doc Text:
GRE network interfaces now start correctly A change introduced in the previous release of Red Hat Enterprise Linux 6 introduced a bug which in some cases caused `initscripts` to fail to correctly start Generic Routing Encapsulation (GRE) network interfaces. This update provides a fix to `initscripts` that ensures GRE interfaces start as expected.
Clone Of:
: 1441289 (view as bug list)
Environment:
Last Closed: 2018-06-19 05:20:44 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1908 None None None 2018-06-19 05:21:22 UTC

Description Dmitry Melekhov 2017-03-27 04:36:00 UTC
Description of problem:

I have 2 gre interfaces in system, after upgrade only first is up
after reboot or network start.


Version-Release number of selected component (if applicable):

9.03.58-1.el6 



How reproducible:


Steps to Reproduce:
1. create 2 gre inetrfaces, first on in my case has type IPIP, second is GRE
2. upgrade
3. reboot

Actual results:

No gre2:



Expected results:
gre2 in system


Additional info:

@@ -98,11 +98,6 @@
continue
fi

- if [ "$TYPE" = "IPSEC" ] || [ "$TYPE" = "IPIP" ] || [ "$TYPE" = "GRE" ]; then
- vpninterfaces="$vpninterfaces $i"
- continue
- fi
-
if [ "${DEVICE%%.*}" != "$DEVICE" -o "${DEVICE##vlan}" != "$DEVICE" ] ; then
vlaninterfaces="$vlaninterfaces $i"
continue
@@ -192,11 +187,6 @@

if [ -z "$DEVICE" ] ; then DEVICE="$i"; fi

- if [ "$TYPE" = "IPSEC" ] || [ "$TYPE" = "IPIP" ] || [ "$TYPE" = "GRE" ]; then
- vpninterfaces="$vpninterfaces $i"
- continue
- fi
-
if [ "$TYPE" = "Bridge" ]; then
bridgeinterfaces="$bridgeinterfaces $i"
continue

There was chages in scripts for GRE and IPIP interfaces.

Reverting system back to previous network script solves problem.

Thank you!

Comment 2 David Kaspar [Dee'Kej] 2017-03-27 12:07:27 UTC
Hello, thank you for you bug report.

(In reply to Need Real Name from comment #0)
> Version-Release number of selected component (if applicable):
> 
> 9.03.58-1.el6 
Is this is the version of initscripts currently failing for you? Later you wrote that reverting changes solved the issue. I just want to be sure which version are we talking about.

> Steps to Reproduce:
> 1. create 2 gre inetrfaces, first on in my case has type IPIP, second is GRE
> 2. upgrade
What exactly do you mean by upgrade? I assume you mean 'sudo yum upgrade' - am I right?
> 3. reboot

Best regards,

David

Comment 3 Dmitry Melekhov 2017-03-27 12:14:10 UTC
Initscripts with problem:

rpm -qi initscripts
Name        : initscripts                  Relocations: (not relocatable)
Version     : 9.03.58                           Vendor: Red Hat, Inc.
Release     : 1.el6                         Build Date: Срд 18 Янв 2017 16:24:11
Install Date: Чтв 23 Мар 2017 09:36:26      Build Host: x86-041.build.eng.bos.redhat.com
Group       : System Environment/Base       Source RPM: initscripts-9.03.58-1.el6.src.rpm

I just copied network script from previous version to solve problem.

By upgrade I mean yes, yum upgrade which installs version I mentioned above, with problem in network script.

Comment 4 David Kaspar [Dee'Kej] 2017-03-27 12:40:32 UTC
OK, thank you for the information. We will look into this, but I can't guarantee any time frame at the moment. We are currently engaged in RHEL-7.4 development phase.

Thank you for your understanding.

David

Comment 5 Dmitry Melekhov 2017-03-27 12:45:56 UTC
Not a problem , previous version works just fine.
Thank you!

Comment 6 Lukáš Nykrýn 2017-03-27 13:39:25 UTC
https://github.com/fedora-sysv/initscripts/pull/86

Comment 9 Dmitry Melekhov 2017-03-27 16:46:58 UTC
tested patch, everything is fine now, thank you.
hope update for RHEL will be released soon :-)

Comment 18 Dmitry Melekhov 2017-04-26 04:02:53 UTC
Almost a month passed since I reported bug.
Still no official fix?

Comment 19 David Kaspar [Dee'Kej] 2017-04-26 11:14:24 UTC
(In reply to Need Real Name from comment #18)
> Almost a month passed since I reported bug.
> Still no official fix?

This BZ has been proposed for Z-Stream accelerated fix.
You can track the progress here:
https://bugzilla.redhat.com/show_bug.cgi?id=1441289

However, I can't provide you with any release dates and so, I hope you understand. :)

Comment 20 Steve Almy 2017-04-26 17:16:28 UTC
(In reply to Need Real Name from comment #18)
> Almost a month passed since I reported bug.
> Still no official fix?

Please contact Red Hat Support (https://www.redhat.com/en/services/support) for help with this fix.

Thanks,
Steve

Comment 22 Dmitry Melekhov 2017-04-26 17:55:30 UTC
Steve, fortunately I have only self-support subscription, so 
https://bugzilla.redhat.com/show_bug.cgi?id=1436061#c9

Comment 30 errata-xmlrpc 2018-06-19 05:20:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1908


Note You need to log in before you can comment on or make changes to this bug.