Bug 1436120 - 7-Zip Compression test doesn't run and result not printed in web browser.
Summary: 7-Zip Compression test doesn't run and result not printed in web browser.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: phoronix-test-suite
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Markus Mayer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-27 08:36 UTC by Hemanth
Modified: 2017-06-29 02:47 UTC (History)
1 user (show)

Fixed In Version: phoronix-test-suite-7.2.0-1.fc25 phoronix-test-suite-7.2.0-1.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-28 20:51:40 UTC
Type: Bug


Attachments (Terms of Use)
LOG: ~/.phoronix-test-suite/installed-tests/pts/compress-7zip-1.6.2/install-failed.log (1.35 KB, text/plain)
2017-03-27 08:36 UTC, Hemanth
no flags Details

Description Hemanth 2017-03-27 08:36:51 UTC
Created attachment 1266580 [details]
LOG: ~/.phoronix-test-suite/installed-tests/pts/compress-7zip-1.6.2/install-failed.log

Description of problem:
 7-Zip Compression task doesn't produce expected results

Version-Release number of selected component (if applicable):
 	
phoronix-test-suite-7.0.0-1.fc25

How reproducible:
always

Steps to Reproduce:
1.Install phoronix-test-suite-7.0.0-1.fc25 from updates-testing repository
2.Start phoronix-test-suite from menu,choose first Task 1.Run a Test
3. After that select test no. 2. 7-Zip Compression   - Processor ,and run it.

Actual results:
The installer exited with a non-zero exit status.
 ERROR: cpp: fatal error: '-c' is not a valid option to the preprocessor
 LOG: ~/.phoronix-test-suite/installed-tests/pts/compress-7zip-1.6.2/install-failed.log
[PROBLEM] pts/compress-7zip-1.6.2 is not installed. 
[PROBLEM] You must enter at least one test, suite, or result identifier to run. 

Opens a 'file not found' page in web browser with address- file:///home/hethkar/.phoronix-test-suite/test-results//index.html 

Expected results:
Run the test and ask prompts to save the result
Open the results in web browser

Additional info:
Fedora 25 installed in KVM

Comment 1 Markus Mayer 2017-03-27 19:47:39 UTC
I just tried to reproduce this on my Fedora 25 machine and it worked as expected. 
Can you check which binary you are actual using for compilation?
Please provide the output of:
- 'which g++' and 'ls -la $(which g++)'

Comment 2 Hemanth 2017-03-28 14:25:40 UTC
(In reply to Markus Mayer from comment #1)
> I just tried to reproduce this on my Fedora 25 machine and it worked as
> expected. 
> Can you check which binary you are actual using for compilation?
> Please provide the output of:
> - 'which g++' and 'ls -la $(which g++)'

which g++
/usr/bin/which: no g++ in (/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/home/hethkar/.local/bin:/home/hethkar/bin)

ls -la $(which g++)
/usr/bin/which: no g++ in (/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/home/hethkar/.local/bin:/home/hethkar/bin)
total 192
drwx------. 24 hethkar hethkar  4096 Mar 28 19:28 .
drwxr-xr-x.  3 root    root     4096 Mar 20 15:02 ..
-rw-------.  1 hethkar hethkar  6823 Mar 28 02:20 .bash_history
-rw-r--r--.  1 hethkar hethkar    18 Sep 30 13:55 .bash_logout
-rw-r--r--.  1 hethkar hethkar   193 Sep 30 13:55 .bash_profile
-rw-r--r--.  1 hethkar hethkar   231 Sep 30 13:55 .bashrc
drwx------. 26 hethkar hethkar  4096 Mar 28 19:42 .cache
drwxrwxr-x.  4 hethkar hethkar  4096 Mar 28 19:28 .cinnamon
drwxr-xr-x. 33 hethkar hethkar  4096 Mar 28 19:43 .config
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 22 11:52 Desktop
-rw-------.  1 hethkar hethkar    48 Mar 27 14:57 .directory
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 27 14:24 Documents
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 28 01:24 Downloads
-rw-rw-r--.  1 hethkar hethkar   628 Mar 23 05:50 .equake_appletrc
-rw-------.  1 hethkar hethkar    16 Mar 20 15:08 .esd_auth
drwx------.  3 hethkar hethkar  4096 Mar 23 04:02 .gnupg
-rw-r--r--.  1 hethkar hethkar    76 Mar  4  2015 .gtkrc-2.0-kde4
-rw-------.  1 hethkar hethkar  3112 Mar 28 19:28 .ICEauthority
drwxrwxr-x.  2 hethkar hethkar  4096 Mar 23 04:00 .icons
drwxrwxr-x.  3 hethkar hethkar  4096 Mar 27 18:22 .kde
-rw-------.  1 hethkar hethkar    67 Mar 27 13:26 .lesshst
drwx------.  3 hethkar hethkar  4096 Mar 20 15:08 .local
drwxr-xr-x.  5 hethkar hethkar  4096 Mar 20 16:47 .mozilla
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 20 15:09 Music
drwxrwxr-x. 11 hethkar hethkar  4096 Mar 28 19:32 .phoronix-test-suite
drwxr-xr-x.  3 hethkar hethkar  4096 Mar 27 19:45 Pictures
drwxrw----.  3 hethkar hethkar  4096 Mar 20 16:23 .pki
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 20 15:09 Public
drwx------.  7 hethkar hethkar  4096 Mar 28 02:16 .rocksndiamonds
drwx------.  2 hethkar hethkar  4096 Mar 20 15:23 .ssh
drwxrwxr-x.  5 hethkar hethkar  4096 Mar 23 05:17 .stellarium
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 20 15:09 Templates
drwxrwxr-x.  2 hethkar hethkar  4096 Mar 23 04:00 .themes
drwxr-xr-x.  2 hethkar hethkar  4096 Mar 20 15:09 Videos
-rw-rw-r--.  1 hethkar hethkar 21832 Mar 26 23:29 .xfce4-session.verbose-log
-rw-rw-r--.  1 hethkar hethkar 25248 Mar 24 01:29 .xfce4-session.verbose-log.last

Comment 3 Markus Mayer 2017-03-29 19:57:35 UTC
It looks like gcc-c++ is not installed on your system. Phoronix-test-suite should install missing dependencies automatically.

Could you post the output of:
- dnf info gcc-c++
- phoronix-test-suite install-dependencies pts/compress-7zip

Comment 4 Hemanth 2017-03-30 12:00:03 UTC
Yes i was thinking if dependencies were missing it should have installed them automatically,but i am not sure about the issue here.

# dnf info gcc-c++
Last metadata expiration check: 7 days, 13:32:44 ago on Thu Mar 23 03:50:31 2017.
Available Packages
Name        : gcc-c++
Arch        : i686
Epoch       : 0
Version     : 6.3.1
Release     : 1.fc25
Size        : 10 M
Repo        : updates
Summary     : C++ support for GCC
URL         : http://gcc.gnu.org
License     : GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and
            : LGPLv2+ and BSD
Description : This package adds C++ support to the GNU Compiler Collection.
            : It includes support for most of the current C++ specification,
            : including templates and exception handling.

Name        : gcc-c++
Arch        : x86_64
Epoch       : 0
Version     : 6.3.1
Release     : 1.fc25
Size        : 11 M
Repo        : updates
Summary     : C++ support for GCC
URL         : http://gcc.gnu.org
License     : GPLv3+ and GPLv3+ with exceptions and GPLv2+ with exceptions and
            : LGPLv2+ and BSD
Description : This package adds C++ support to the GNU Compiler Collection.
            : It includes support for most of the current C++ specification,
            : including templates and exception handling.

# phoronix-test-suite install-dependencies pts/compress-7zip

The above command only gives a blank line as output

Comment 5 Markus Mayer 2017-03-30 19:54:46 UTC
Thank you for the information. I was able to locate the bug in the code and submitted a bug upstream. https://github.com/phoronix-test-suite/phoronix-test-suite/issues/164

Regardless if upstream fixes the bug or not, I will create an update to 7.0.1 and will fix this within the fedora package. But it may take about a week, before I find the time for this.

Comment 6 Markus Mayer 2017-03-30 20:05:50 UTC
I forgot to mention: If you need a quick fix just 'dnf install gcc-c++'

Comment 7 Fedora Update System 2017-06-16 09:23:30 UTC
phoronix-test-suite-7.2.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-12ea5c8c0e

Comment 8 Fedora Update System 2017-06-16 09:23:38 UTC
phoronix-test-suite-7.2.0-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c6be3ccf5

Comment 9 Fedora Update System 2017-06-16 19:50:26 UTC
phoronix-test-suite-7.2.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-12ea5c8c0e

Comment 10 Fedora Update System 2017-06-16 19:53:00 UTC
phoronix-test-suite-7.2.0-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-4c6be3ccf5

Comment 11 Fedora Update System 2017-06-28 20:51:40 UTC
phoronix-test-suite-7.2.0-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-06-29 02:47:29 UTC
phoronix-test-suite-7.2.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.