Bug 1436133 - vmlinuz is not properly transferred to /boot and kdump fails
vmlinuz is not properly transferred to /boot and kdump fails
Status: CLOSED DUPLICATE of bug 1392904
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng (Show other bugs)
4.0.7
Unspecified Unspecified
unspecified Severity high
: ovirt-4.1.2
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-27 05:18 EDT by Roman Hodain
Modified: 2017-03-27 19:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-27 19:39:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2982141 None None None 2017-03-27 06:56 EDT

  None (edit)
Description Roman Hodain 2017-03-27 05:18:35 EDT
Description of problem:
When a rhvh is upgraded the new initramfs is not transferred to /boot and kdump service fails during the boot process.

Version-Release number of selected component (if applicable):
imgbased-0.8.11-0.1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. Intall hypervisor before version rhvh-4.0-0.20170307.0
2. Upgrade to rhvh-4.0-0.20170307


Actual results:
Mar 27 09:11:10 localhost systemd[1]: Starting Crash recovery kernel arming...
Mar 27 09:11:11 localhost kdumpctl[1977]: Error: /boot/vmlinuz-3.10.0-514.10.2.el7.x86_64 not found.
Mar 27 09:11:11 localhost kdumpctl[1977]: Starting kdump: [FAILED]


Expected results:
The kdump initramfs is properly generated based on the vmlinuz and stored in /boot
Comment 2 Ryan Barry 2017-03-27 19:39:48 EDT
imgbased-copy-bootfiles is present in 4.1, which resolves this

*** This bug has been marked as a duplicate of bug 1392904 ***

Note You need to log in before you can comment on or make changes to this bug.