Bug 143619 - SMB printer configuration issue in redhat-config-printer
SMB printer configuration issue in redhat-config-printer
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-22 17:19 EST by Need Real Name
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-23 18:45:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2004-12-22 17:19:48 EST
Description of problem:
I have read a number of reports, both on Bugzilla and the Internet
regarding this problem, but none of the resolutions have fixed mine.

Please keep in mind I am very very new at working in Linux. So keep
any communications at a layman's level, please.

I am trying to set up a new printer configuration.  I am on my home
LAN.  I have two other computers connected to the LAN, one running XP
Home edition and the other XP Pro.  My Printer, an HP 953C Deskjet is
connected to the XP Pro via a USB port.  All computers go through a
Lynksys 4 port router to the Internet.


Version-Release number of selected component (if applicable):
I have all current updates to Fedora Core 2 and using kernel-2.6.9-1.6_FC2

How reproducible:
Every attempt to add a new printer.

Steps to Reproduce:
1. At the 'Printer configuration - localhost.localdomain' screen I
choose 'New'
2. At the 'Add a new print queue' screen 
Name: e3110q
Description: HP 952C
3. I selected 'Networked Windows (SMB)' as the Queue type. No printer
information was displayed
4. So, I clicked 'Specify' and filled in:

Workgroup: Workgroup (name of the workgroup on the machine the printer
is attached to)
Server: Rdell (the computer name of the machine the printer is
attached to)
Share: dellprin (the Share Name of the printer on the machine the
printer is attached to)
User Name:  I tried 'guest'.  I also tried the user name that the
cable company initially set on my computer, but neither worked.
Password: With User Name, guest, I didn't use a password.  With my
User Name I used the password that was set up by the cable company.
  
Actual results:
Authentication window goes away and comes back with not additional
feed back.  Repeated clicks on 'OK' have the same results.

Expected results:
The printer should have been identified and configured.

Additional info:
Output of 'printconf-tui --Xexport' (an entry I saw on another bug
report, hope it helps)

<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="local" SERIAL="1103638011">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        </print_queues>
      <sharing_globals TYPE="LIST">
        <browsing TYPE="BOOL" VALUE="TRUE"/>
        </sharing_globals>
      </printconf>
    </datatree>
  </adm_context>
Comment 1 Tim Waugh 2004-12-23 06:32:23 EST
Please try this from a command line:

rpcclient -c enumprinters localhost -N

What does it say?
Comment 2 Need Real Name 2004-12-23 07:35:08 EST
The response to: 
rpcclient -c enumprinters localhost -n

Error connecting to 127.0.0.1 (Connection refused)
cli_full_connection: failed to connect to LOCALHOST<20> (127.0.0.1)
Cannot connect to server.  Error was NT_STATUS_UNSUCCESSFUL
Comment 3 Tim Waugh 2004-12-23 08:02:19 EST
Oh, sorry I meant this command:

rpcclient -c enumprinters Rdell -N

Please remember to use a capital N, though, not lowercase.
Comment 4 Need Real Name 2004-12-23 08:52:29 EST
The response to: 
rpcclient -c enumprinters Rdell -n

cli_full_connection: failed to connect to RDELL<20> (0.0.0.0)
Cannot connect to server.  Error was NT_STATUS_UNSUCCESSFUL
Comment 5 Tim Waugh 2004-12-23 10:38:44 EST
Are you sure the name 'Rdell' is correct?  It doesn't seem to be.

Does it show up when you double click on the 'Network' icon in the window that
comes up when you double-click on 'Computer' on the desktop? (You might have to
double-click on 'Workgroup' as well.)
Comment 6 Need Real Name 2004-12-23 16:04:12 EST
Tim, My son has been working on this and got it going.  He had to use the IP
address of the computer with the printer connected to it instead of the computer
name, the printer share name and the Username and password for the host computer.

I really appreciate your time on this bug report and hope you have a safe and
Happy Holiday season.  Thank you.

Note You need to log in before you can comment on or make changes to this bug.