Bug 1436249 - Print audio codec used for record/playback channels during channel creation in debug outputs
Summary: Print audio codec used for record/playback channels during channel creation i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice-gtk
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: SPICE QE bug list
Victor Toso
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-27 13:54 UTC by David Jaša
Modified: 2017-08-01 15:06 UTC (History)
5 users (show)

Fixed In Version: spice-gtk-0.33-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1436251 (view as bug list)
Environment:
Last Closed: 2017-08-01 15:06:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1849 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2017-08-01 17:49:46 UTC

Description David Jaša 2017-03-27 13:54:37 UTC
Description of problem:
It's useful to know what codec is used for playback/record channels so spice-gtk could print to debug output at channel creation.

Version-Release number of selected component (if applicable):
spice-gtk3-0.33-1.el7.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Victor Toso 2017-03-27 14:07:49 UTC
At channel creation we don't know. We know based on SPICE_MSG_PLAYBACK_MODE message which we print a message (in playback):

https://cgit.freedesktop.org/spice/spice-gtk/tree/src/channel-playback.c#n349

I guess it would be more clear to include the mode/codec as string when we recebe the start message (SPICE_MSG_PLAYBACK_START and SPICE_MSG_RECORD_START).

Looks good to you?

Comment 2 David Jaša 2017-03-28 09:06:23 UTC
(In reply to Victor Toso from comment #1)
> At channel creation we don't know. We know based on SPICE_MSG_PLAYBACK_MODE
> message which we print a message (in playback):
> 
> https://cgit.freedesktop.org/spice/spice-gtk/tree/src/channel-playback.c#n349
> 
> I guess it would be more clear to include the mode/codec as string when we
> recebe the start message (SPICE_MSG_PLAYBACK_START and
> SPICE_MSG_RECORD_START).
> 
> Looks good to you?

Yeah, that would be great. Thanks!

Comment 4 Victor Toso 2017-04-07 10:03:02 UTC
Patch pushed 7721d0906d55cfaa6ce8f5786829c5c738adf74c

Comment 7 errata-xmlrpc 2017-08-01 15:06:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1849


Note You need to log in before you can comment on or make changes to this bug.