Bug 1436319 - "Truncated search results" pop-up appears in user details in WebUI
Summary: "Truncated search results" pop-up appears in user details in WebUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: IPA Maintainers
QA Contact: Varun Mylaraiah
URL:
Whiteboard:
Depends On:
Blocks: 1515190
TreeView+ depends on / blocked
 
Reported: 2017-03-27 16:21 UTC by Petr Vobornik
Modified: 2017-11-20 11:15 UTC (History)
7 users (show)

Fixed In Version: ipa-4.5.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1515190 (view as bug list)
Environment:
Last Closed: 2017-08-01 09:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Petr Vobornik 2017-03-27 16:21:02 UTC
Cloned from upstream: https://pagure.io/freeipa/issue/6618

When more users than configured sizelimit exist, a pop-up stating that search limit has been exceeded is shown when viewing user details in WebUI.

Steps to reproduce on an existing IPA server:

    1. $ ipa config-mod --searchrecordslimit=5
    2. $ for i in {300..305}; do ipa user-add "test$i" --first T --last T ; done
    3. visit example.com/ipa/ui/#/e/user/details/test300

Comment 2 Petr Vobornik 2017-03-27 16:21:49 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6618

Comment 3 Petr Vobornik 2017-03-27 16:23:36 UTC
ipa-4-5:
    422c9058d9a6be69db4eab7db654b9184ae5eab6 WebUI: Add support for suppressing warnings
    697a5779b377a5d76c1cb212514b6feb46326f71 WebUI: suppress truncation warning in select widget
   

master:
    7b3a10da7001d7ee394cd891d926def66d0f2546 WebUI: Add support for suppressing warnings
    b9e6ad1967ba24c7ebe5181da1ebe32d30e7b28f WebUI: suppress truncation warning in select widget

Comment 4 Petr Vobornik 2017-03-27 16:24:56 UTC
I'd like to see this fix in 7.4. 

The warning is quite annoying in larger setups. Not sure if it is a regression.

Comment 6 Varun Mylaraiah 2017-05-30 10:54:34 UTC
Verified 
ipa-server-4.5.0-13.el7.x86_64
warning message not popping up.

Comment 7 errata-xmlrpc 2017-08-01 09:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.