Bug 1436338 - CLI doesn't work after ipa-restore
Summary: CLI doesn't work after ipa-restore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Pavel Picka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-27 16:59 UTC by Petr Vobornik
Modified: 2017-08-01 09:46 UTC (History)
6 users (show)

Fixed In Version: ipa-4.5.0-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:46:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
output (3.03 KB, text/plain)
2017-06-06 10:55 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2304 normal SHIPPED_LIVE ipa bug fix and enhancement update 2017-08-01 12:41:35 UTC

Description Petr Vobornik 2017-03-27 16:59:27 UTC
Cloned from upstream: https://pagure.io/freeipa/issue/6748

Steps to reproduce:

* ipa-backup
* ipa-server-install --uninstall
* ipa-restore
* kinit admin
* ipa ping

```text
[root@vm-058-129 ~]# ipa ping
ipa: ERROR: No valid Negotiate header in server response
```
httpd error log:
```text
[Thu Mar 09 18:43:50.024163 2017] [auth_gssapi:error] [pid 77550] [client 2620:52:0:224e:21a:4aff:fe23:1211:42306] gss_acquire_cred[_from]() failed to get server creds: [Unspecified GSS failure.  Minor code may provide more information ( SPNEGO cannot find mechanisms to negotiate)], referer: https://vm-058-129.abc.idm.lab.eng.brq.redhat.com/ipa/xml
```

Comment 2 Petr Vobornik 2017-03-27 16:59:41 UTC
Upstream ticket:
https://pagure.io/freeipa/issue/6748

Comment 3 Petr Vobornik 2017-03-27 17:00:50 UTC
master (maybe in rebase):
    ee6d031a6a0939c1f51a874b1f8f9b19ec727203 Backup KDC certificate pair

master:
    2612c092dd797c9c8f772c785aae1f152f06847d Backup ipa-specific httpd unit-file

ipa-4-5:
    59342a7f6fffe2aaf0b8ce4e10bb41444d8fa25f Backup ipa-specific httpd unit-file


Not setting POST, Web UI still doesn't work after restore.

Comment 6 Pavel Picka 2017-06-06 10:55:38 UTC
Created attachment 1285339 [details]
output

Verified on ipa-server-4.5.0-14.el7.x86_64

Comment 7 errata-xmlrpc 2017-08-01 09:46:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2304


Note You need to log in before you can comment on or make changes to this bug.