Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 143653 - should install grub menu entry
should install grub menu entry
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: memtest86+ (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-23 07:04 EST by Russell Coker
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-01 16:49:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2004-12-23 07:04:10 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.3; Linux) (KHTML, like Gecko)

Description of problem:
When this package is installed /boot/grub/grub.conf should be updated to add an entry for booting it.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Install it and observe no change in /boot/grub/menu.conf

Additional info:
Comment 1 Warren Togami 2004-12-23 14:44:43 EST
Sorry.  An earlier version of memtest86+ did have it, but I was told
to remove it from %post because it would fail during anaconda install
where /boot/grub/grub.conf does not exist.

/usr/sbin/memtest-setup was included to automatically configure your
grub.conf.  Uninstall of memtest86+ removes that menu entry too.
Comment 2 Warren Togami 2004-12-23 18:05:40 EST
On second thought...
Jeremy, would you accept it if memtest86+ edited /boot/grub/grub.conf
only if it exists in %post, otherwise do nothing?
Comment 3 Jeremy Katz 2004-12-24 10:45:13 EST
And then you'll get bugs about differing behvaior when it's installed
by the installer versus not.
Comment 4 Warren Togami 2005-01-01 16:49:06 EST
Alrighty.  WONTFIX unless someone has a better idea.

Note You need to log in before you can comment on or make changes to this bug.