Bug 143656 - Installer crashes reading RPMs info to install after several asserts in disk_dos.c on previous pages
Installer crashes reading RPMs info to install after several asserts in disk_...
Status: CLOSED DUPLICATE of bug 138419
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-12-23 09:38 EST by Yury Lebedev
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Anaconda Crash Dump (995.13 KB, text/plain)
2004-12-23 09:40 EST, Yury Lebedev
no flags Details

  None (edit)
Description Yury Lebedev 2004-12-23 09:38:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; 
SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322)

Description of problem:
There is some trouble installing Fedora from DVD on dual-boot 
computer with Windows XP and RedHat 9.0 - installer throws many 
assertions like 'Assertion (heads>0) at disk_dos.c:485 in 
pbe_partition_for_geom() failed' and 'Assertion (sectors<=63) at 
disk_dos.c:490 in pbe_partition_for_geom() failed' switching between 
pages and crashes reading RPMs info from DVD in any intall/upgrade 
mode. Anaconda dump file will be attached to this bug.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Download Fedora Core 3 ISO DVD image and burn it
2. Boot from DVD and start installer with defaults
3. Choose any initial installer options on first pages
4. Press Cancel on disk_dos.c assertions (if you press Ignore, 
installer breaks its process)
4. Choose custom install in reinstall mode (or Upgrade existing found 
RedHat 9.0) - see also strange duplicate of hda1 item in DiskDruid 
marked as 'unallocated space'
5. See Anaconda crash dialog on reading RPMs stage

Additional info:

Intel Pentium 4 CPU 3.2GHz hyper-threaded, 1G ROM, single 120G hard 
drive (hda1 NTFS, hda2 FAT32, hda3 ext3 '/', hda5 ext3 '/usr', hda6 
ext3 '/usr/local', hda7 swap, hda8 FAT32)

Dual-boot Windows XP SP2, RedHat 9.0 with GRUB on hda MBR
Comment 1 Yury Lebedev 2004-12-23 09:40:45 EST
Created attachment 109076 [details]
Anaconda Crash Dump
Comment 2 Jeremy Katz 2004-12-23 10:12:41 EST

*** This bug has been marked as a duplicate of 138419 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:07:47 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.