Bug 1436617 - [RFE] Virt-who can check configuration for validity
Summary: [RFE] Virt-who can check configuration for validity
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-who   
(Show other bugs)
Version: 7.4
Hardware: x86_64 Linux
high
low
Target Milestone: rc
: ---
Assignee: Chris Snyder
QA Contact: Eko
Yehuda Zimmerman
URL:
Whiteboard:
Keywords: FutureFeature, Triaged
: 1490244 (view as bug list)
Depends On:
Blocks: 1469152 1500914
TreeView+ depends on / blocked
 
Reported: 2017-03-28 10:18 UTC by Eko
Modified: 2018-04-10 16:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
*virt-who* now provides configuration error information The *virt-who* utility now checks for common *virt-who* configuration errors and outputs log messages that specify the configuration items that caused these errors. As a result, it is easier for a user to correct *virt-who* configuration errors.
Story Points: ---
Clone Of:
: 1500914 (view as bug list)
Environment:
Last Closed: 2018-04-10 16:19:53 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0895 None None None 2018-04-10 16:21 UTC

Comment 2 Kevin Howell 2017-03-30 15:02:46 UTC
Eko, can you please attach the config files used?
Please tell us which values in the config you believe should cause an error?
What error message/feedback do you expect?

Comment 4 Kevin Howell 2017-04-03 19:26:10 UTC
We are thinking that we would like to handle this as an RFE which does something like this: a virt-who subcommand that validates the config, reports any problems (including ignored keys), and validates connections with candlepin and virtualization backends.

Comment 5 Chris Snyder 2017-09-25 14:13:41 UTC
*** Bug 1490244 has been marked as a duplicate of this bug. ***

Comment 8 yuefliu 2017-11-02 10:53:17 UTC
The bug still exists with virt-who-0.21.0-1.el7.noarch.

Comment 14 errata-xmlrpc 2018-04-10 16:19:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0895


Note You need to log in before you can comment on or make changes to this bug.