Bug 1436762 - Stack delete does not delete Swift ring container
Summary: Stack delete does not delete Swift ring container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-common
Version: 11.0 (Ocata)
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Christian Schwede (cschwede)
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-28 15:07 UTC by Joe Talerico
Modified: 2017-05-17 20:15 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-common-6.0.0-6.el7ost
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-05-17 20:15:13 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 444219 None None None 2017-03-29 08:28:02 UTC
OpenStack gerrit 451937 None None None 2017-04-04 14:40:19 UTC
Launchpad 1671783 None None None 2017-03-28 15:07:28 UTC

Description Joe Talerico 2017-03-28 15:07:28 UTC
Description of problem:
TripleO Deployment succeeded, however importing a image into glance fails. This seems to be due to :
"The container to store Swift rings is not deleted when the stack is deleted. This results in re-deploying old rings when deploying a new stack, which is misleading especially when testing.

The rings itself will get fixed over time by puppet, but nevertheless old rings should be deleted when the stack itself gets deleted."

Version-Release number of selected component (if applicable):
OSP11 Passed Phase 1 

How reproducible:
50%

Steps to Reproduce:
1. Deploy (succeeds, works)
2. Delete stack
3. Deploy again (fails to import image)

Actual results:
Failure to import image into glance

Expected results:
Import works.


Additional info:

Comment 1 Christian Schwede (cschwede) 2017-03-29 08:28:03 UTC
Proposed new patch upstream that fixes this issue: https://review.openstack.org/444219

Comment 2 Red Hat Bugzilla Rules Engine 2017-04-04 14:54:04 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 3 Jon Schlueter 2017-04-04 15:00:08 UTC
openstack-tripleo-common-6.0.0-6.el7ost

Comment 8 errata-xmlrpc 2017-05-17 20:15:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.