Bug 1436782 - [RFE] package ceph-ansible for Ubuntu
Summary: [RFE] package ceph-ansible for Ubuntu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Other
urgent
urgent
Target Milestone: rc
: 3.0
Assignee: Ken Dreyer (Red Hat)
QA Contact: Madhavi Kasturi
Erin Donnelly
URL:
Whiteboard:
Depends On:
Blocks: 1494421
TreeView+ depends on / blocked
 
Reported: 2017-03-28 16:08 UTC by Uday Boppana
Modified: 2017-12-05 23:33 UTC (History)
11 users (show)

Fixed In Version: Ubuntu: ceph-ansible_3.0.0~rc3-2redhat1
Doc Type: Enhancement
Doc Text:
.A Red Hat Ceph Storage cluster can be deployed from an Ubuntu node by using Ansible Previously, Red Hat did not provide the `ceph-ansible` package for Ubuntu. With this update, you can use the Ansible automation application to deploy a Ceph cluster from an Ubuntu node. For details, see the https://access.redhat.com/documentation/en/red_hat_ceph_storage/3/single/installation_guide_for_ubuntu/#installing-a-red-hat-ceph-storage-cluster[Installing a Red Hat Ceph Storage Cluster] section in the Installation Guide for Ubuntu.
Clone Of:
Environment:
Last Closed: 2017-12-05 23:33:43 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1434175 None None None Never
Red Hat Product Errata RHBA-2017:3387 normal SHIPPED_LIVE Red Hat Ceph Storage 3.0 bug fix and enhancement update 2017-12-06 03:03:45 UTC

Internal Links: 1434175

Description Uday Boppana 2017-03-28 16:08:58 UTC
Description of problem:
Ceph-Ansible support to run from a Ubutu host 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 3 seb 2017-03-29 12:29:13 UTC
That's already the case, what's the problem?
We support Ubuntu 16.04 at the moment.

Comment 9 Madhavi Kasturi 2017-10-11 05:42:10 UTC
RHCS 3.0 ubuntu cluster installation completed successfully from an Ubuntu host.

ubuntu@magna003:$ dpkg -l | grep ansible
ii  ansible                            2.3.2.0-2redhat1                           all          A radically simple IT automation platform
ii  ceph-ansible                       3.0.0~rc19-2redhat1                        all          Ansible playbooks for Ceph

ubuntu@magna003:~$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 16.04.3 LTS
Release:	16.04
Codename:	xenial

Comment 14 errata-xmlrpc 2017-12-05 23:33:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3387


Note You need to log in before you can comment on or make changes to this bug.