Bug 1436800 - python-jsonschema: python3-jsonschema is missing Python 3 version of executables
python-jsonschema: python3-jsonschema is missing Python 3 version of executables
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-jsonschema (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alan Pevec
Fedora Extras Quality Assurance
:
: 1419376 (view as bug list)
Depends On:
Blocks: PY3-EXECUTABLES
  Show dependency treegraph
 
Reported: 2017-03-28 13:32 EDT by Iryna Shcherbina
Modified: 2017-07-23 18:49 EDT (History)
4 users (show)

See Also:
Fixed In Version: python-jsonschema-2.6.0-1.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-23 18:49:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New version including Python 3 executable fix (5.22 KB, patch)
2017-07-21 07:57 EDT, Jan Beran
no flags Details | Diff
Patch to avoid unpacked parts (1.90 KB, patch)
2017-07-21 07:59 EDT, Jan Beran
no flags Details | Diff

  None (edit)
Description Iryna Shcherbina 2017-03-28 13:32:05 EDT
The Python 3 subpackage python3-jsonschema is missing executables available in the Python 2 subpackage.

According to the Fedora Packaging guidelines for Python [0], if a Python package that supports Python 3 installs executables into /usr/bin,  then either both Python versions of the executables should be packaged, or only the Python 3 version, depending on the functionality they provide.
(Note the "should": having Python 2-only executables is permitted, but strongly discouraged.)

Is it intentional for this particular package?

In case it is not intentional, please provide a Python 3 version of executable, or you can just switch to Python 3 if the functionality is the same regardless of the Python version. The guide for porting Python-based RPMs is available here [1] and you may refer to it for more instructions.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 26 as well.

If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing the issue!

[0] https://fedoraproject.org/wiki/Packaging:Python#Avoiding_collisions_between_the_python_2_and_python_3_stacks
[1] http://python-rpm-porting.readthedocs.io/
Comment 1 Jan Beran 2017-07-21 07:57 EDT
Created attachment 1302317 [details]
New version including Python 3 executable fix
Comment 2 Jan Beran 2017-07-21 07:59 EDT
Created attachment 1302318 [details]
Patch to avoid unpacked parts
Comment 3 Jan Beran 2017-07-21 08:05:59 EDT
Hi Alan,

may I ask you to review the updated spec file, and if it is correct, to make a new Fedora build? Thank you.
Comment 4 Alan Pevec 2017-07-21 18:21:13 EDT
*** Bug 1419376 has been marked as a duplicate of this bug. ***
Comment 5 Alan Pevec 2017-07-23 18:49:26 EDT
Thanks Jan!

Note You need to log in before you can comment on or make changes to this bug.