Bug 1436838 - -v 'value' deprecated and replaced with -p 'param'
Summary: -v 'value' deprecated and replaced with -p 'param'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: cns-deploy-tool
Version: cns-3.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: CNS 3.5
Assignee: Mohamed Ashiq
QA Contact: Prasanth
URL:
Whiteboard:
Depends On:
Blocks: 1415600
TreeView+ depends on / blocked
 
Reported: 2017-03-28 19:37 UTC by Mohamed Ashiq
Modified: 2018-12-18 06:50 UTC (History)
7 users (show)

Fixed In Version: cns-deploy-4.0.0-11.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 18:29:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1112 normal SHIPPED_LIVE cns-deploy-tool bug fix and enhancement update 2017-04-20 22:25:47 UTC

Description Mohamed Ashiq 2017-03-28 19:37:27 UTC
Description of problem:
Error log seen in cns-deploy

role "edit" added: "system:serviceaccount:aplo:heketi-service-account"
Flag --value has been deprecated, Use -p, --param instead.
Flag --value has been deprecated, Use -p, --param instead.
service "deploy-heketi" created
route "deploy-heketi" created
deploymentconfig "deploy-heketi" created


Version-Release number of selected component (if applicable):
# oc version
oc v3.5.5
kubernetes v1.5.2+43a9be4
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://10.70.46.216:8443
openshift v3.5.5
kubernetes v1.5.2+43a9be4

# rpm -qa | grep cns
cns-deploy-4.0.0-9.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
Run cns-deploy

Comment 2 Mohamed Ashiq 2017-03-28 19:48:03 UTC
Patch Upstream:

https://github.com/gluster/gluster-kubernetes/pull/216

Comment 6 Michael Adam 2017-03-30 16:05:19 UTC
PR has been superseded by

https://github.com/gluster/gluster-kubernetes/pull/222

which has been merged. Will get into next build.

Comment 8 Prasanth 2017-04-03 10:44:13 UTC
Verified as fixed in cns-deploy-4.0.0-11.el7rhgs.x86_64

Comment 9 errata-xmlrpc 2017-04-20 18:29:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1112


Note You need to log in before you can comment on or make changes to this bug.