Bug 143686 - acroread doesn't have src.rpm - up2date fails
acroread doesn't have src.rpm - up2date fails
Status: CLOSED DUPLICATE of bug 126528
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: up2date (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Max Spevack
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-23 23:39 EST by Eric Hagberg
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 09:58:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Hagberg 2004-12-23 23:39:56 EST
Description of problem:
This is using rhel3...

Testing package set / solving RPM inter-dependencies...
########################################
acroread-5.10-0.EL3.i386.rp ########################## Done.
File Not Found: acroread-5.10-0.EL3.src.rpm

Error Message:
    Invalid RPM package acroread-5.10-0.EL3.src.rpm requested
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


Version-Release number of selected component (if applicable):


How reproducible: always


Steps to Reproduce:
1. configure up2date to pull source packages automatically
2. "up2date -u --nox"
3. see above error output
  
Actual results:


Expected results:


Additional info:
Comment 1 Eric Hagberg 2004-12-24 09:26:09 EST
additionally, the acroread package in the x86_64 channel hasn't yet
been updated to the 5.10 version that's in the i386 channel.
Comment 2 Eric Hagberg 2005-01-20 10:32:11 EST
Any update to this?
Comment 3 Eric Hagberg 2005-03-15 14:30:29 EST
Anyone? In RHEL4, this is again/still a problem with the RealPlayer rpm:

Testing package set / solving RPM inter-dependencies...
########################################
RealPlayer-10.0.3-1.i386.rp ########################## Done.
File Not Found: RealPlayer-10.0.3-1.src.rpm
 
Error Message:
    Invalid RPM package RealPlayer-10.0.3-1.src.rpm requested
Error Class Code: 17
Error Class Info: File not found.
Explanation:
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.
Comment 5 Adrian Likins 2005-05-17 15:01:13 EDT
Since this is more of a feature request than a bug fix (up2date
does not crash) I'm deferring this for this release.
Comment 6 Eric Hagberg 2005-05-17 15:12:33 EDT
up2date doesn't crash, but it fails to complete. I'd call this a bug.

All you need to do is make sure that a src.rpm is present, even if it's got to
be a dummy src.rpm, for every rpm you've got available from up2date.

Why can't that be done anytime before another release?
Comment 13 Clifford Perry 2006-03-27 12:38:40 EST
There is currently no plans to fix this within the Enterprise Linux 3 version of
up2date. 

Regards,
Clifford. 
Comment 15 Eric Hagberg 2006-04-11 17:23:24 EDT
Same problem exists for RHEL4. Will that get ignored until just before its last
update as well, or might it get fixed?
Comment 19 Frank Hirtz 2006-05-04 09:58:48 EDT

*** This bug has been marked as a duplicate of 126528 ***

Note You need to log in before you can comment on or make changes to this bug.