Bug 143695 - missing libdb.so.3
missing libdb.so.3
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: db3 (Show other bugs)
3.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jindrich Novy
http://www.veccal.ernet.in
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-24 06:37 EST by Joydev Lahiri
Modified: 2013-07-02 19:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-16 17:20:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joydev Lahiri 2004-12-24 06:37:40 EST
Description of problem:

This applies to RHEL3 AS/ES/WS Update 4

Database coonectivity causes problems because of 

missing /usr/lib/libidb.so.3


Version-Release number of selected component (if applicable):
compat-db-4.0.14-5.1 rpm

How reproducible:
Always

Steps to Reproduce:
1.just do rpm -Va|tee rpmva and examine the rpmva
2.
3.
  
Actual results:

missing /usr/lib/libidb.so.3

Expected results:
libidb.so.3 should not go missing

Additional info:
Downgrading compat-db-4.0.14-5.1 rpm to compat-db-4.0.14-5 does not
work-- rather that makes the system unstable.

This problem is not applicable to RHEL3 AS/ES/WS Update 3
Comment 1 Joydev Lahiri 2004-12-24 07:49:58 EST
Reported by Joydev Lahiri <joy@veccal.ernet.in>
Comment 2 Joydev Lahiri 2004-12-25 10:02:44 EST
A typo has occurred: it's not libidb but
missing /usr/lib/libdb.so.3
Just do
rpm -V compat-db

The rpm version is
compat-db-4.0.14-5.1
as supplied with RHEL3 AS/ES/WS Update 4 (kernel 2.4.21-27.EL)

Reported by
Joydev Lahiri<joy@veccal.ernet.in>
Comment 3 Joydev Lahiri 2004-12-27 01:05:10 EST
Am having problems installing third party applications due to the 
missing shared library libdb.so.3. A quick resolution would be 
appreciated. You may send me a patch.
Joydev Lahiri <joy@veccal.ernet.in>
Comment 4 Joydev Lahiri 2004-12-27 23:16:14 EST
I guess /usr/lib/libdb.so.3 is a symlink which for some reason compat-
db rpm is unable to create. Would appreciate if you can tell me to 
what it is symlinked to. Then the following might work:

#root> ln -s /usr/lib/libdb.so.3 /you/tell/me
#root> /sbin/ldconfig

Joydev Lahiri<joy@veccal.ernet.in> 
Comment 5 Arjan van de Ven 2004-12-30 06:13:47 EST
it should be symlinked to /lib/libdb2.so.3
Comment 7 RHEL Product and Program Management 2006-12-16 17:20:51 EST
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.