Bug 143696 - irssi does not load perl scripts
Summary: irssi does not load perl scripts
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: irssi
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dams
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-24 12:17 UTC by Christopher Stone
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-01-30 10:30:23 UTC


Attachments (Terms of Use)

Description Christopher Stone 2004-12-24 12:17:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041111 Firefox/1.0

Description of problem:
irssi does not load in any script files, and the /script command does not work.  Probably because perl is not being loaded into irssi.

The irssi package over at dag wieers works fine. 
http://dag.wieers.com/packages/irssi/

Version-Release number of selected component (if applicable):
irssi-0.8.9-4

How reproducible:
Always

Steps to Reproduce:
1.  Run irssi
2.  Type /script

  

Actual Results:  It says "script" command not found.

Expected Results:  It should show a list of scripts that have been loaded.

Additional info:

Comment 1 Michael Schwendt 2004-12-24 14:49:58 UTC
Doesn't look like a bug. You need to '/load perl' when Perl support is
an optional module and not built in by default. Dag's version has Perl
built in instead of a module.


Comment 2 Christopher Stone 2004-12-24 14:58:50 UTC
Fair enough, but might I suggest building irssi with the perl module 
built in, as 99.99% of users are going to be using scripts with 
irssi anyway, having it as a module doesn't make much sense.

Comment 3 Michael Schwendt 2004-12-24 15:22:13 UTC
Users, who use perl scripts in irssi, do use the $HOME/.irssi/startup
file, don't they? They would put /load perl in there. With perl
support being a module, /unload perl would still work and increase
flexibility. I'm not the package maintainer, but I don't think
hardcoding perl should be a goal. With perl built in, the sequence
/unload perl /load perl gives confusing errors, btw.


Comment 4 Dams 2005-01-30 10:30:23 UTC
I agree with Michael, and i dont see why we should/must hard-link perl
inside irssi, and i prefer modular things. 
It's a matter of taste, i guess.


Note You need to log in before you can comment on or make changes to this bug.