Bug 143698 - Too many included dictionaries cause performance problems in OOo
Too many included dictionaries cause performance problems in OOo
Status: CLOSED DUPLICATE of bug 124374
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
Depends On:
  Show dependency treegraph
Reported: 2004-12-24 07:49 EST by Max Kanat-Alexander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-28 00:16:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
My very-long dictionary.lst (1.39 KB, text/plain)
2004-12-24 07:49 EST, Max Kanat-Alexander
no flags Details

  None (edit)
Description Max Kanat-Alexander 2004-12-24 07:49:07 EST
Not everybody seems to have this problem (according to #fedora on IRC), but I
have it on both my home machine and work machine.

Basically, if I right-click on a misspelled word, OOo locks up for about two or
three minutes, sometimes even locking up X, while I wait for it to load in a lot
of dictionaries.

I ran it through strace, and I found out that it was loading every dictionary
for every language when I right-clicked on a word.

To check if it was my settings, I deleted ~/.rhopenoffice* and ~/.openoffice*
and ran OOo again. The same problem occured, even with default settings.

If I edit /usr/lib/ooo-1.1/share/dict/ooo/dictionary.lst to include only the
en_US dictionaries, then the problem doesn't occur. It's perfectly fast.

So, a few questions:
(1) Why aren't these dictionaries in the -i18n package?
(2) Why is OOo searching all dictionaries when I haven't told it to, and my
Language Settings are correctly set to their default settings?

If it's relevant, both installations were upgraded from FC1 -> FC2 -> FC3.

Version-Release number of selected component (if applicable):

How reproducible: Always

Steps to Reproduce:
1. Turn on AutoCheck for Spelling.
2. Type a misspelled word.
3. Right-click on that word.
Actual results:
Hard Drive spins for two minutes, OOo grows huge in RAM.

Expected results:
Right-click menu comes up immediately.

Additional Info:
Here's the output of "ls /usr/lib/ooo-1.1/share/dict/ooo/":
bg_BG.aff           en_NZ.aff       hyph_fr_FR.dic  pl_PL.dic
bg_BG.dic           en_NZ.dic       hyph_hu_HU.dic  pt_BR.aff
ca_ES.aff           en_US.aff       hyph_it_IT.dic  pt_BR.dic
ca_ES.dic           en_US.dic       hyph_nl_NL.dic  pt_PT.aff
da_DK.aff           es_ES.aff       hyph_pl_PL.dic  pt_PT.dic
da_DK.dic           es_ES.dic       hyph_pt_BR.dic  README_en_GB.txt
de_AT.aff           es_MX.aff       hyph_pt_PT.dic  README_it_IT.txt
de_AT.dic           es_MX.dic       hyph_ru_RU.dic  ru_RU.aff
de_CH.aff           FontOOo.sxw     hyph_sk_SK.dic  ru_RU.dic
de_CH.dic           fr_FR.aff       hyph_sl_SI.dic  sk_SK.aff
de_DE.aff           fr_FR.dic       hyph_sv_SE.dic  sk_SK.dic
de_DE.dic           hr_HR.aff       hyph_uk_UA.dic  sl_SI.aff
DicOOo.sxw          hr_HR.dic       it_IT.aff       sl_SI.dic
dictionary.lst      hu_HU.aff       it_IT.dic       sv_SE.aff
dictionary.lst.old  hu_HU.dic       la_LA.aff       sv_SE.dic
el_GR.aff           hyph_da_DK.dic  la_LA.dic       th_de_DE.dat
el_GR.dic           hyph_de_CH.dic  nb_NO.aff       th_de_DE.idx
en_AU.aff           hyph_de_DE.dic  nb_NO.dic       th_en_US.dat
en_AU.dic           hyph_en_CA.dic  nl_NL.aff       th_en_US.idx
en_CA.aff           hyph_en_GB.dic  nl_NL.dic       th_hu_HU.dat
en_CA.dic           hyph_en_US.dic  nn_NO.aff       th_hu_HU.idx
en_GB.aff           hyph_es_ES.dic  nn_NO.dic       uk_UA.aff
en_GB.dic           hyph_fr_BE.dic  pl_PL.aff       uk_UA.dic
Comment 1 Max Kanat-Alexander 2004-12-24 07:49:07 EST
Created attachment 109107 [details]
My very-long dictionary.lst
Comment 2 Sitsofe Wheeler 2004-12-24 15:30:04 EST
This is a dup of bug 124374
Comment 3 Max Kanat-Alexander 2004-12-28 00:16:09 EST
Ah, you're right. I suspect that bug has so many dupes because it doesn't have
the word "spell checker" or "dictionary" in the summary. :-)

*** This bug has been marked as a duplicate of 124374 ***

Note You need to log in before you can comment on or make changes to this bug.