Bug 1437 - Linux won't properly configurate the 2 button mouses.
Summary: Linux won't properly configurate the 2 button mouses.
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig
Version: 5.2
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
: 1698 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-06 15:42 UTC by witriew86
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-03-29 22:24:34 UTC


Attachments (Terms of Use)

Description witriew86 1999-03-06 15:42:55 UTC
I have a Microsoft PS/2 mouse and a Generic Serial mouse. I
tried them both on Linux in mouseconfig but every time it
clicks in "Emulate 3 Buttons" even though I never clicked
it. When I used the Microsoft PS/2 mouse, I tried to go into
X-Windows the mouse always fails and the system crashes, but
when I use the Generic Serial mouse I can move the pointer
but the movement isn't smooth and the pointer jumps all over
the screen and I cant control it.

Comment 1 Jeff Johnson 1999-03-23 22:41:59 UTC
*** Bug 1698 has been marked as a duplicate of this bug. ***

With MS mouse attached to the ps2 port of an alpha, ran
mouseconfig selected generic ps2 mouse, checked emulate 3
buttons.  The paste operation fails in a VC.  Works in X.

Comment 2 Preston Brown 1999-03-26 15:29:59 UTC
It turns on emulate 3 buttons because 2 button mice NEED to have the
third button emulated.  What are the contents of your
/etc/sysconfig/mouse when you have the microsoft PS/2 mouse attached?
What sort of microsoft PS/2 mouse is it? (model numbers on bottom of
mouse).

Comment 3 Preston Brown 1999-03-26 15:34:59 UTC
Please also note that after you change your mouse type with
mouseconfig, in Red Hat 5.2 and earlier, you NEED TO RE-RUN
Xconfigurator for X to pick up your mouse changes.  This will not be
the case in the next release of Red Hat Linux, but as it is now, it is
clearly stated in both mouseconfig and the mouseconfig man page.


Note You need to log in before you can comment on or make changes to this bug.