Bug 1437034 - [RFE] apply VLAN_EGRESS_PRIORITY_MAP option when configuring it via ifcfg files
Summary: [RFE] apply VLAN_EGRESS_PRIORITY_MAP option when configuring it via ifcfg files
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: initscripts
Version: 7.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: David Kaspar [Dee'Kej]
QA Contact: Leos Pol
URL:
Whiteboard:
Keywords: FutureFeature, Patch
Depends On:
Blocks: 1384222 1446211
TreeView+ depends on / blocked
 
Reported: 2017-03-29 11:09 UTC by Fani Orestiadou
Modified: 2017-08-01 07:31 UTC (History)
6 users (show)

(edit)
New directive VLAG_EGRESS_PRIORITY_MAP directive for ifcfg-* interface files introduced.

This new directive allows to change the egress priority of each network interface when it is not controlled by NetworkManager.
Clone Of:
(edit)
Last Closed: 2017-08-01 07:31:31 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2286 normal SHIPPED_LIVE initscripts bug fix and enhancement update 2017-08-01 11:26:43 UTC

Description Fani Orestiadou 2017-03-29 11:09:19 UTC
Description of problem:
VLAN_EGRESS_PRIORITY_MAP option is not applied by modifying the ifcfg files when NetworkManager is not handling the vlan interface. 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.3 (Maipo)
3.10.0-514.2.2.el7.x86_64
NetworkManager-1.4.0-13.el7_3.x86_64                        Sun Feb 26 12:12:09 2017

How reproducible: Have the interface not handled my NetworkManager and change the egress option manually by editing the ifcfg file.

Steps to Reproduce:
1. Edit the ifcfg file with the desired priority
2. Restart network service
3. Check /proc/net/vlan/vlanX

Actual results:
The priority is not applied. 

- With NM_CONTROLLED=yes

[root@localhost ~]# cat /proc/net/vlan/team0.10 
team0.10  VID: 10	 REORDER_HDR: 1  dev->priv_flags: 1
         total frames received            0
          total bytes received            0
      Broadcast/Multicast Rcvd            0

      total frames transmitted           11
       total bytes transmitted         1650
Device: team0
INGRESS priority mappings: 0:0  1:0  2:0  3:0  4:0  5:0  6:0 7:0
 EGRESS priority mappings: 
[root@localhost ~]# vi /etc/sysconfig/network-scripts/ifcfg-team0.10 
[root@localhost ~]# grep -i egress /etc/sysconfig/network-scripts/ifcfg-team0.10
VLAN_EGRESS_PRIORITY_MAP=0:3,1:3,2:3,3:3,4:3,5:3,6:3,7:3
[root@localhost ~]# systemctl restart network 
[root@localhost ~]# cat /proc/net/vlan/team0.10 
team0.10  VID: 10	 REORDER_HDR: 1  dev->priv_flags: 1
         total frames received            0
          total bytes received            0
      Broadcast/Multicast Rcvd            0

      total frames transmitted           10
       total bytes transmitted         1308
Device: team0
INGRESS priority mappings: 0:0  1:0  2:0  3:0  4:0  5:0  6:0 7:0
 EGRESS priority mappings: 0:3 1:3 2:3 3:3 4:3 5:3 6:3 7:3 <---

- With NM_CONTROLLED=no 

[root@localhost ~]# egrep -i -e  "NM|egress" /etc/sysconfig/network-scripts/ifcfg-team0.10
VLAN_EGRESS_PRIORITY_MAP=0:3,1:3,2:3,3:3,4:3,5:3,6:3,7:3
NM_CONTROLLED=no

[root@localhost ~]# cat /proc/net/vlan/team0.10 
team0.10  VID: 10	 REORDER_HDR: 1  dev->priv_flags: 1
         total frames received            0
          total bytes received            0
      Broadcast/Multicast Rcvd            0

      total frames transmitted           22
       total bytes transmitted         3161
Device: team0
INGRESS priority mappings: 0:0  1:0  2:0  3:0  4:0  5:0  6:0 7:0
 EGRESS priority mappings:     <---------


Expected results:
Have the egress priority mapping applied. 

Additional info: 
Customer is not able to use NetworkManager because they are using Redhat OSP for Openstack, and it is required to have it disabled.

Let me know if more info is required. 

Thank you, 
Fani

Comment 2 Lukáš Nykrýn 2017-03-29 13:15:45 UTC
We don't support that in initscripts, but patch should be quite trivial.

https://github.com/fedora-sysv/initscripts/pull/88

Comment 3 Fani Orestiadou 2017-03-29 13:56:01 UTC
Hello Lukas, 

Thank you for your reply. I would like to know though the reason why we don't support this. Do you mean that is not yet implemented and we can proceed with RFE or that generally will not be supported from our side?

Thank you

Comment 4 Lukáš Nykrýn 2017-03-29 15:42:32 UTC
Well it was never requested before. But if you want to give to your customer something to test, the patch to add it is just one line and you can find it here:
https://github.com/fedora-sysv/initscripts/pull/88/commits/1c889b45bfe8ec3c2f49b338f99964fc47596b03

Comment 5 Fani Orestiadou 2017-03-30 07:55:02 UTC
Hello Lukas, 

The request is coming from a strategic customer and the feature is quite important for them. Is it possible to have it implemented on RHEL 7.4? 

Thank you, 
Fani

Comment 11 David Kaspar [Dee'Kej] 2017-04-11 14:09:02 UTC
Pull request merged into upstream:
https://github.com/fedora-sysv/initscripts/pull/88

Comment 12 David Kaspar [Dee'Kej] 2017-05-03 10:25:06 UTC
This is now part of RHEL-7 branch:
https://github.com/fedora-sysv/initscripts/pull/95

Comment 14 Leos Pol 2017-06-23 19:11:06 UTC
initscripts-9.49.39-1.el7 verified by TC

Comment 16 errata-xmlrpc 2017-08-01 07:31:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2286


Note You need to log in before you can comment on or make changes to this bug.