Bug 143707 - Dovecot package update to latest version
Dovecot package update to latest version
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dovecot (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
: FutureFeature
Depends On:
Blocks: 145214
  Show dependency treegraph
 
Reported: 2004-12-24 11:05 EST by Pedro Silva
Modified: 2014-01-21 17:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-22 15:55:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pedro Silva 2004-12-24 11:05:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
If possible, I would like to request a package update of dovecot for
Fedora Core 2.

FC2 latest version, 0.99.10.5
FC3 latest version, 0.99.11
Dovecot latest version, 0.99.12

Version 0.99.11 has some important fixes related to mail clients,
changelog here:
http://www.dovecot.org/list/dovecot/2004-September/004582.html

Version 0.99.12 has also important fixes, changelog here:
http://www.dovecot.org/list/dovecot/2004-December/005443.html

I know the update cycle of fc2 is almost ending but maybe this is doable.

Version-Release number of selected component (if applicable):
dovecot-0.99.10.5-0.FC2

How reproducible:
Always

Steps to Reproduce:
1. On fc2,  rpm -q dovecot
2. On fc3,  rpm -q dovecot
3. www.dovecot.org
    

Additional info:
Comment 1 John Dennis 2005-01-10 14:02:33 EST
Actually the current release is 0.99.13. I have rebuilt it for FC2
along with some other fixes and additional documentation. I built the
same rpm for FC3 and have tested it locally without any problems.
Below is a pointer to the candidate version for FC2 in my private
area. Would you be willing to trying installing this version? I would
feel beter if someone in a production environment tested this in FC2
before I push it out to the whole channel.

ftp://people.redhat.com/jdennis/dovecot-0.99.13-1.FC2.i386.rpm

Let me know if you can do this and if so what your results were.

Thanks!
Comment 2 Pedro Silva 2005-01-10 17:36:28 EST
I'm running fc2+2.6.9-1.6_FC2(latest kernel hangs)+freshrpms+fedora.us.

I've downloaded your rpm and as root:

rpm -Uvh dovecot-0.99.13-1.FC2.i386.rpm
error: Failed dependencies:
        perl(Date::Parse) is needed by dovecot-0.99.13-1.FC2

yum install perl-TimeDate, worked.

Dovecot seems to be up and available.
I'll update bugzilla if something breaks.

Thanks for your reply.
Comment 3 Warren Togami 2005-01-10 19:12:04 EST
[root@vserver tmp]rpm -Uvh dovecot-0.99.13-1.FC2.i386.rpm
/etc/security/selinux/file_contexts: No such file or directory
error: Failed dependencies:
        libpq.so.3 is needed by dovecot-0.99.13-1.FC2
[root@vserver tmp]cat /etc/fedora-release
Fedora Core release 2 (Tettnang)

Something changed since dovecot-0.99.10.5-0.FC2.  What is this?
Comment 4 Pedro Silva 2005-01-10 19:49:51 EST
I'm using thunderbird 0.9-1.fc3 and now i can't open my inbox.

/var/log/maillog

imap-login: Login: pedrofsilva [::ffff:10.10.10.10]
imap(pedrofsilva): open(/var/mail/pedrofsilva.lock) failed: Permission denied
imap(pedrofsilva): file_lock_dotlock() failed with mbox file
/var/mail/pedrofsilva: Permission denied
imap(pedrofsilva): open(/var/mail/pedrofsilva.lock) failed: Permission denied
imap(pedrofsilva): file_lock_dotlock() failed with mbox file
/var/mail/pedrofsilva: Permission denied

However, i can view messages on other imap folders on the same account.
Comment 5 John Dennis 2005-01-11 18:20:35 EST
With respect to comment #3

Something did change, the newer versions of dovecot are capable of 
using either postgres or mysql for user lookup's. Although a 
BuildRequires was added for both the postgres and mysql devel 
packages I had missed adding the prereq's. This is why installation 
failed for libpq.so.3, which is a postgres library. I didn't detect 
this failed dependecy because I have both of these database rpm 
installed :-( I'm updating the spec file now to add these prereq's.

With respect to comment #2

I presently cannot explain the prereq on Perl(Date::Parse) and I'm 
investigating why this seems like a new prereq, at the moment I don't 
see a reason for it.
Comment 6 John Dennis 2005-01-11 18:29:40 EST
With respect to comment #4 from Pedro

What is the value of mbox_locks in /etc/dovecot.conf?

Try setting it to just fcntl (watch for a comment character # at the 
front of the line, if its there uncomment the setting) then restart 
dovecot (/sbin/service dovecot restart) Does that fix your problem?

Can you tell me how thunderbird is configured to use imap? It would 
seem from the error that somebody other than root or mail is invoking 
dovecot which to the best of my understanding should not be the case 
if you've got the imap server running as a root daemon and you're 
connecting via an IMAP port.
Comment 7 Pedro Silva 2005-01-11 19:09:27 EST
Yes, the mbox_locks was set to:

mbox_locks = dotlock fcntl

It works with: mbox_locks = fcntl.

I'm using one fc2 box for sendmail+fetchmail+dovecot(imaps only) and a client
box running fc3+thunderbird with several mail accounts on the dovecot box.

Regarding the dovecot's IDLE feature for mail clients, which work best with
evolution/thunderbird/outlook? 
Comment 8 Pedro Silva 2005-01-12 14:20:40 EST
Everything seems to be running ok.

Last night I installed squirrelmail-1.4.3a-6.FC2 and configured to use
dovecot(imaps) and it's also working.

Regarding dovecot's IDLE feature, i've been using thunderbird 0.9-1.fc3, and it
has been working flawlessly, checking for new messages and new mail notification
is working. I haven't tested evolution and/or outlook.
Comment 9 John Dennis 2005-01-12 17:25:19 EST
Thank you for the feedack Pedro. Other than fixing the package
dependencies I think this rpm is good to go.

I think I have a solution to problem with dotlocks. For dotlocks to
work with our spool directory the process creating the lock file has
to be either root or in the group "mail". The imap process executes
with the privledges of the authenticated user and normal users are not
normally in the group "mail". I found a configuration option called
"mail_extra_groups" which can be set in the config file. I have not
had a chance to experiment with this yet, but from reading the code
(and the doc in the config file) I believe if you set
"mail_extra_groups" to "mail" (no quotes) you should be able to turn
dotlocking back on.
Comment 10 Pedro Silva 2005-01-13 18:03:33 EST
It works. By changing the mail_extra_groups to mail (it's a comment in default
/etc/dovecot.conf) and mbox_locks to "dotlock fcntl" (default config), both
thunderbird and squirrelmail work sucessfully.

Thanks for the support.
Comment 11 Warren Togami 2005-01-13 19:24:26 EST
I personally use fnctl and have been very happy.
Comment 12 John Dennis 2005-01-14 15:50:27 EST
The following two RPM's have been prepared for release in the update
channel. I was going to push them out today (Friday) but I think I'll
wait till Monday in case someone wants to try them out early as a test
over the weekend. They've had some testing, no problems so far, but
more testing before the push to the wide community is always better.
If you do test before Monday 1/17/05 just add a quick note to this
bugzilla with your results. Thanks!

This is for FC2:
ftp://people.redhat.com/jdennis/dovecot-0.99.13-3.FC2.i386.rpm

This is for FC3:
ftp://people.redhat.com/jdennis/dovecot-0.99.13-2.FC3.i386.rpm
Comment 13 Warren Togami 2005-01-15 02:44:34 EST
[root@server tmp]rpm -Uvh dovecot-0.99.13-3.FC2.i386.rpm
error: Failed dependencies:
        postgresql is needed by dovecot-0.99.13-3.FC2

This is an artificial dependency that is unneeded.  It was fine
without the dependency on "postgresql" because of RPM's auto-dep
resolution which pulls in postgresql-libs.  "Prereq: postgresql" is
simply wrong and should be removed.  It was fine before.
Comment 14 Pedro Silva 2005-01-15 11:13:32 EST
rpm -Uvh /home/d3vice/dovecot-0.99.13-3.FC2.i386.rpm
Preparing...                ########################################### [100%]
   1:dovecot                warning: /etc/dovecot.conf created as
/etc/dovecot.conf.rpmnew
########################################### [100%]

Thunderbird and Squirrelmail work with no problems (apparently).

Regarding WTogami's comment, I'm already using postgresql, that's why that
dependency never showed up. I agree that it should be removed.
Comment 15 shrek-m 2005-01-15 12:22:39 EST
fedora-updates  !=  fedora-updates-testing

$ yum list dovecot
Installed Packages
dovecot.i386                             0.99.11-1.FC3.4        installed
Available Packages
dovecot.i386                             0.99.13-2.FC3         
updates-released
Comment 16 Warren Togami 2005-01-15 18:18:50 EST
jdennis, I think Bug 145214 should be also be solved before issuing a dovecot
update.  It is BAD that a previously working default configuration no longer
works without manual intervention.  Looks like some kind of ugly %post magic is
our only option to add the new config option?
Comment 17 Warren Togami 2005-01-15 18:42:31 EST
Additionally a decision on Bug 145241 should be made.

After these changes are made, I would highly recommend pushing a package like
this to updates-testing for a few days before pushing this as an official update.
Comment 18 Matthew Miller 2005-04-26 11:44:51 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Note You need to log in before you can comment on or make changes to this bug.