Bug 1437101 - Pkgconf breaks golang
Summary: Pkgconf breaks golang
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgconf
Version: 26
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1437223 (view as bug list)
Depends On:
Blocks: BaseRuntimeFTBFS
TreeView+ depends on / blocked
 
Reported: 2017-03-29 13:14 UTC by Jakub Čajka
Modified: 2017-04-27 19:51 UTC (History)
4 users (show)

Fixed In Version: pkgconf-1.3.4-1.fc26 pkgconf-1.3.5-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-27 19:51:42 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Jakub Čajka 2017-03-29 13:14:29 UTC
Description of problem:
pkgconf break golang(testsuite). It seems that new pkgconf incorrectly evaluates "Cflags: -Dhello=10 -Dworld=+32 -DDEFINED_FROM_PKG_CONFIG=hello\ world"
in to "-Dhello=10 -Dworld=+32 -DDEFINED_FROM_PKG_CONFIG=helloworld" and thus breaking golang test suite case "TestCgoPkgConfig". Test is not failing in f25 or older and did passed with pkgconf 1.2.2-2(https://koji.fedoraproject.org/koji/buildinfo?buildID=861725)

Version-Release number of selected component (if applicable):
pkgconf 1.3.3

How reproducible:
Always

Steps to Reproduce:
1. try to build golang package(go1.8 in rawhide/f26)

Actual results:
golang build fails with failed "TestCgoPkgConfig" test

Expected results:
golang build passes


Additional info:
golang test file https://github.com/golang/go/blob/master/src/cmd/go/go_test.go (search for ^^ mentioned test case)

Comment 1 Jakub Čajka 2017-03-30 08:12:25 UTC
*** Bug 1437223 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2017-03-30 08:22:58 UTC
pkgconf-1.3.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ca466f7baf

Comment 3 Fedora Update System 2017-03-30 08:23:08 UTC
pkgconf-1.3.4-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-ca466f7baf

Comment 4 Fedora Update System 2017-03-30 08:23:23 UTC
pkgconf-1.3.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-787e6173a1

Comment 5 Fedora Update System 2017-03-30 08:23:29 UTC
pkgconf-1.3.4-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-787e6173a1

Comment 6 Fedora Update System 2017-03-30 18:52:15 UTC
pkgconf-1.3.4-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-ca466f7baf

Comment 7 Fedora Update System 2017-03-31 03:21:25 UTC
pkgconf-1.3.4-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-787e6173a1

Comment 8 Fedora Update System 2017-04-01 17:33:04 UTC
pkgconf-1.3.4-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-04-05 06:45:12 UTC
pkgconf-1.3.5-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fa482d6f73

Comment 10 Fedora Update System 2017-04-05 19:54:23 UTC
pkgconf-1.3.5-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fa482d6f73

Comment 11 Fedora Update System 2017-04-27 19:51:42 UTC
pkgconf-1.3.5-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.