Bug 1437103 - Validations always fail from the GUI, and their output is blank
Summary: Validations always fail from the GUI, and their output is blank
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-validations
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: beta
: 11.0 (Ocata)
Assignee: Florian Fuchs
QA Contact: Ola Pavlenko
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-29 13:16 UTC by Udi
Modified: 2017-05-17 20:15 UTC (History)
7 users (show)

Fixed In Version: openstack-tripleo-validations-5.4.0-7.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:15:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 453183 None None None 2017-04-05 12:32:08 UTC
Launchpad 1678029 None None None 2017-04-02 17:41:46 UTC

Description Udi 2017-03-29 13:16:49 UTC
Description of problem:
You can successfully run a validation from CLI with:
run-validation <path-to-validator> <path-to-ssh-key> <plan-name>

b.t.w. you can get the ssh key from:
mistral environment-get ssh_keys

But when you start the validations from the GUI they fail, and when you click on one to see the failure - the output in it is blank.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-3.1.0-4.el7ost.noarch (puddle 2017-03-24)


How reproducible:
100%


Steps to Reproduce:
1. Run a validator from the GUI

Comment 4 Florian Fuchs 2017-03-31 11:13:38 UTC
Upstream bug report and fix:

- https://bugs.launchpad.net/tripleo/+bug/1678029
- https://review.openstack.org/#/c/452147/

Comment 5 Florian Fuchs 2017-04-05 14:49:32 UTC
Fix has landed upstream: https://review.openstack.org/#/c/453183/

Comment 7 Ola Pavlenko 2017-04-09 07:47:53 UTC
Verified 
openstack-tripleo-ui-3.1.0-8.el7ost.noarch

Comment 8 errata-xmlrpc 2017-05-17 20:15:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.