Bug 1437177 - python-pbr: python3-pbr is missing Python 3 version of executables
Summary: python-pbr: python3-pbr is missing Python 3 version of executables
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pbr   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jan Beran
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PY3-EXECUTABLES
TreeView+ depends on / blocked
 
Reported: 2017-03-29 17:15 UTC by Iryna Shcherbina
Modified: 2017-07-17 17:17 UTC (History)
5 users (show)

Fixed In Version: python-pbr-3.1.1-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-17 17:17:09 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix of missing Python 3 version of executables in python3-pbr subpackage (7.43 KB, patch)
2017-07-17 09:28 UTC, Jan Beran
no flags Details | Diff

Description Iryna Shcherbina 2017-03-29 17:15:15 UTC
The Python 3 subpackage python3-pbr is missing executables available in the Python 2 subpackage.

According to the Fedora Packaging guidelines for Python [0], if a Python package that supports Python 3 installs executables into /usr/bin,  then either both Python versions of the executables should be packaged, or only the Python 3 version, depending on the functionality they provide.
(Note the "should": having Python 2-only executables is permitted, but strongly discouraged.)

Is it intentional for this particular package?

In case it is not intentional, please provide a Python 3 version of executable, or you can just switch to Python 3 if the functionality is the same regardless of the Python version. The guide for porting Python-based RPMs is available here [1] and you may refer to it for more instructions.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 26 as well.

If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing the issue!

[0] https://fedoraproject.org/wiki/Packaging:Python#Avoiding_collisions_between_the_python_2_and_python_3_stacks
[1] http://python-rpm-porting.readthedocs.io/

Comment 1 Lumír Balhar 2017-06-01 09:08:45 UTC
Hello.

Is there any way how can I help you with this. We need to move this forward because as you can see here [0] a lot of packages depends on the python-pbr.

[0] http://fedora.portingdb.xyz/pkg/python-pbr/

Comment 2 Matthias Runge 2017-07-01 06:39:51 UTC
Sorry, I missed this. pbr is quite low in my prio list, as it is been a dependency of one of my former packages; I might have some time in the future, but am totally unsure.

Comment 3 Jan Beran 2017-07-17 09:28 UTC
Created attachment 1299746 [details]
Fix of missing Python 3 version of executables in python3-pbr subpackage

Comment 4 Jan Beran 2017-07-17 09:30:53 UTC
Hi Matthias, may I ask you to review the fix? Thank you.

Comment 5 Matthias Runge 2017-07-17 11:04:10 UTC
thank you, this looks good to me.


Note You need to log in before you can comment on or make changes to this bug.