Bug 1437183 - python-gearbox: python3-gearbox is missing Python 3 version of executables
Summary: python-gearbox: python3-gearbox is missing Python 3 version of executables
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-gearbox   
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Infrastructure SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: PY3-EXECUTABLES
TreeView+ depends on / blocked
 
Reported: 2017-03-29 17:16 UTC by Iryna Shcherbina
Modified: 2019-02-04 00:23 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 21:54:29 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix of missing Python 3 version executables (4.77 KB, patch)
2017-07-21 14:10 UTC, Jan Beran
no flags Details | Diff

Description Iryna Shcherbina 2017-03-29 17:16:16 UTC
The Python 3 subpackage python3-gearbox is missing executables available in the Python 2 subpackage.

According to the Fedora Packaging guidelines for Python [0], if a Python package that supports Python 3 installs executables into /usr/bin,  then either both Python versions of the executables should be packaged, or only the Python 3 version, depending on the functionality they provide.
(Note the "should": having Python 2-only executables is permitted, but strongly discouraged.)

Is it intentional for this particular package?

In case it is not intentional, please provide a Python 3 version of executable, or you can just switch to Python 3 if the functionality is the same regardless of the Python version. The guide for porting Python-based RPMs is available here [1] and you may refer to it for more instructions.

It's ok to do this in Rawhide only, however, it would be greatly
appreciated if you could push it to Fedora 26 as well.

If anything is unclear, or if you need any kind of assistance, you can
ask on IRC (#fedora-python on Freenode), or reply here. We'll be happy
to help investigating or fixing the issue!

[0] https://fedoraproject.org/wiki/Packaging:Python#Avoiding_collisions_between_the_python_2_and_python_3_stacks
[1] http://python-rpm-porting.readthedocs.io/

Comment 1 Jan Beran 2017-07-21 14:10 UTC
Created attachment 1302438 [details]
Fix of missing Python 3 version executables

Comment 2 Jan Beran 2017-07-21 14:12:06 UTC
Hi, may I ask to review the updated spec file, and if everything is fine, to make Fedora build? Thank you.

Comment 3 Kevin Fenzi 2017-07-24 21:54:29 UTC
Yep. Looks good to me. Applied and built in rawhide. 

https://koji.fedoraproject.org/koji/taskinfo?taskID=20716887

Comment 4 Alan Pevec 2019-01-31 12:58:49 UTC
Do you plan to drop python2-gearbox subpackage for https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3#Phase_2:_Mass_Python_2_Package_Removal ?

Comment 5 Miro Hrončok 2019-02-01 00:31:04 UTC
JFYI python2-gearbox was not automatically requested for removal because it has /usr/bin/gearbox.


Not sure if requesting needinfo on closed bugs will do, feel free to open a separate bugzilla and block PY2REMOVAL.

Comment 6 Kevin Fenzi 2019-02-04 00:23:59 UTC
I moved /usr/bin/gearbox to use the python3 version and dropped the python2 subpackages.


Note You need to log in before you can comment on or make changes to this bug.