Bug 1437222 - OSP10 -> OSP11 upgrade fails on environment using external loadbalancer due to missing haproxy service running on controller nodes
Summary: OSP10 -> OSP11 upgrade fails on environment using external loadbalancer due t...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 11.0 (Ocata)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Sofer Athlan-Guyot
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-03-29 19:56 UTC by Marius Cornea
Modified: 2017-05-17 20:16 UTC (History)
9 users (show)

Fixed In Version: openstack-tripleo-heat-templates-6.0.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-17 20:16:05 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 452460 None None None 2017-04-02 20:42:36 UTC
Launchpad 1677539 None None None 2017-03-30 10:10:03 UTC

Description Marius Cornea 2017-03-29 19:56:49 UTC
Description of problem:
OSP10 -> OSP11 upgrade fails on environment using external loadbalancer due to missing haproxy service running on controller nodes:

[stack@undercloud-0 ~]$ openstack stack failures list overcloud
overcloud.AllNodesDeploySteps.ControllerUpgrade_Step4.1:
  resource_type: OS::Heat::SoftwareDeployment
  physical_resource_id: 590915dd-fbcd-4692-ba17-65ecb673051f
  status: CREATE_FAILED
  status_reason: |
    Error: resources[1]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
    
    TASK [Check pacemaker resource] ************************************************
    ok: [localhost] => (item=rabbitmq)
    failed: [localhost] (item=haproxy) => {"failed": true, "item": "haproxy", "msg": "Resource 'haproxy' doesn't exist in the cib.", "resource_name": "haproxy", "resource_type": null}
    ok: [localhost] => (item=galera)
    	to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/082a4c01-dadc-401b-b899-d0bb868222fb_playbook.retry
    
    PLAY RECAP *********************************************************************
    localhost                  : ok=5    changed=3    unreachable=0    failed=1   
    
    (truncated, view all with --long)
  deploy_stderr: |

overcloud.AllNodesDeploySteps.ControllerUpgrade_Step4.0:
  resource_type: OS::Heat::SoftwareDeployment
  physical_resource_id: 3b5fb93a-0e66-4e83-bb83-f543918d21bc
  status: CREATE_FAILED
  status_reason: |
    Error: resources[0]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
    
    TASK [Check pacemaker resource] ************************************************
    ok: [localhost] => (item=rabbitmq)
    failed: [localhost] (item=haproxy) => {"failed": true, "item": "haproxy", "msg": "Resource 'haproxy' doesn't exist in the cib.", "resource_name": "haproxy", "resource_type": null}
    ok: [localhost] => (item=galera)
    	to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/93cd7e9c-915d-43b5-8201-d4478052a430_playbook.retry
    
    PLAY RECAP *********************************************************************
    localhost                  : ok=7    changed=4    unreachable=0    failed=1   
    
    (truncated, view all with --long)
  deploy_stderr: |

overcloud.AllNodesDeploySteps.ControllerUpgrade_Step4.2:
  resource_type: OS::Heat::SoftwareDeployment
  physical_resource_id: cddc9c0e-71ae-41b8-85dc-3628e3c42f02
  status: CREATE_FAILED
  status_reason: |
    Error: resources[2]: Deployment to server failed: deploy_status_code : Deployment exited with non-zero status code: 2
  deploy_stdout: |
    ...
    
    TASK [Check pacemaker resource] ************************************************
    ok: [localhost] => (item=rabbitmq)
    failed: [localhost] (item=haproxy) => {"failed": true, "item": "haproxy", "msg": "Resource 'haproxy' doesn't exist in the cib.", "resource_name": "haproxy", "resource_type": null}
    ok: [localhost] => (item=galera)
    	to retry, use: --limit @/var/lib/heat-config/heat-config-ansible/8672385f-986d-4346-9e87-87e44d3a523b_playbook.retry
    
    PLAY RECAP *********************************************************************
    localhost                  : ok=5    changed=3    unreachable=0    failed=1   
    
    (truncated, view all with --long)
  deploy_stderr: |


Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-6.0.0-0.6.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP10 with external loadbalancer
2. Upgrade to OSP11

Actual results:
Upgrade fails

Expected results:
Upgrade succeeds.

Additional info:
In https://github.com/openstack/tripleo-heat-templates/blob/master/puppet/services/pacemaker.yaml#L90-L93 the PacemakerResources list contains haproxy which doesn't run on the controller nodes when an external loadbalancer is used.

Comment 3 errata-xmlrpc 2017-05-17 20:16:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.