Bug 143726 - Automatic mounting of CD/DVD does not work (in MB with SATA?)
Automatic mounting of CD/DVD does not work (in MB with SATA?)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-25 11:14 EST by Osmo Laitinen
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-02 21:01:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Osmo Laitinen 2004-12-25 11:14:14 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
FC3 does not mount automatically my CD's or DVD's when inserted to
internal DVD-player. Manual mounting works ok. When I insert CD to my
external CD-player (Sony CRX120E) mounting is automatical.
Tried with "fresh install" and fully updated system, both fails.

There is no error messages available in logs related to this
problem. Only error message which I'm seeing is on boot and is assuming
generated by /etc/udev/scripts/ide-media.sh script:
cat: /proc/ide/hdc/media: Input/output error



Version-Release number of selected component (if applicable):
hal-4.2-1.FC3, kernel-2.6.9-1.681_FC3, udev-039-10.FC3

How reproducible:
Always

Steps to Reproduce:
1. Insert CD/DVD to internal cd-player
2. CD spins for a while, but nothing happens
3.
    

Actual Results:  Nothing (well, the disk spins for awhile and makes sound)

Expected Results:  FC3 should mount automatically the media in
internal player as it does with external player.

Additional info:

I have tried with latest stable udev (udev-039-10.FC3.5) and now I
have installed development version (udev-048-2)
Also tried with kernel-smp-2.6.9-1.1047_FC4, but it did not help.

But after installing 
hal-0.4.2.cvs20041210-1
hal-gnome-0.4.2.cvs20041210-1
from development tree, automounting started to work ok with smp
kernels 2.6.9-1.1047_FC4 and 2.6.9-1.1049_FC4.
When booting with kernel-smp-2.6.9-1.681_FC3 ti does not work.
So it needs at least both latest development kernel and hal (as of
25.12.2004).

So, these should be fixed in stable tree also. Using dev packages is
not most confortable especially when those are not signed with gpg.
Comment 1 David Zeuthen 2005-01-03 14:19:17 EST
Looks like this issue was fixed in a Rawhide kernel - you need to bug
the kernel people to provide a FC3 update with the fix. Reassigning to
kernel.
Comment 2 Dave Jones 2005-07-15 16:25:56 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Dave Jones 2005-10-02 21:01:42 EDT
This bug has been automatically closed as part of a mass update.
It had been in NEEDINFO state since July 2005.
If this bug still exists in current errata kernels, please reopen this bug.

There are a large number of inactive bugs in the database, and this is the only
way to purge them.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.