Bug 1437299 - 26 Alpha RC7 Server DVD has repoclosure errors
26 Alpha RC7 Server DVD has repoclosure errors
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
26
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-03-29 21:42 EDT by Adam Williamson
Modified: 2017-04-04 15:33 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-04 15:33:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-03-29 21:42:11 EDT
Num Packages in Repos: 2830
package: abrt-plugin-bodhi-2.10.0-4.fc26.x86_64 from myrepo
  unresolved deps: 
     libhawkey.so.2()(64bit)
package: python-smbios-2.3.0-4.fc26.x86_64 from myrepo
  unresolved deps: 
     python-ctypes

This is a violation of the Alpha criteria:

"There must be no errors in any package on the release-blocking images which cause the package to fail to install."

https://fedoraproject.org/wiki/Fedora_26_Alpha_Release_Criteria#No_broken_packages

So nominating as an Alpha blocker.

However, I'm inclined to suggest we should change that criterion. It was written back when the anaconda interface made it possible to select individual packages for installation. It hasn't allowed that for a long time now. Also, current dnf behaviour when a package in a group can't be installed is to just omit it, but install all other packages from the group. We're not very happy with this behaviour for other reasons, but it *is* how dnf behaves right now. That means even if you select a package group containing one of the affected packages for install, your install will succeed, it'll just be missing the affect package(s).

Given those considerations I'm not sure it makes sense to block Alpha on this kind of problem any more. But let's discuss it.
Comment 1 Adam Williamson 2017-03-29 21:43:10 EDT
We *really* ought to automate running the repoclosure, fileconflicts and sizecheck tests...
Comment 2 Mike Ruckman 2017-03-29 23:23:15 EDT
Because of how dnf works, I'd be fine with letting this into Alpha - however, we really should discuss a criteria change.

-1 blocker for Alpha.
Comment 3 Dennis Gilmore 2017-03-30 13:06:19 EDT
repoclosure is ran every compose
Comment 4 Adam Williamson 2017-03-30 13:41:24 EDT
Ah, yeah, I guess the Server install repo repoclosure test is close enough to the contents of the DVD. But there is nothing in place to report the result to the wiki.
Comment 5 Adam Williamson 2017-04-04 15:33:59 EDT
Discussed at 2017-03-30 Fedora 26 Alpha Go/No-Go Meeting #2, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-meeting-2/2017-03-30/f26-alpha-go-no-go-meeting-3rd.2017-03-30-17.00.txt . We agreed that it no longer makes sense for this to be part of the Alpha criteria given the current behaviour of anaconda and dnf, and consequently this was rejected as an Alpha blocker. Criteria amendment proposals will follow shortly to test@.

Also closing, as this particular repoclosure issue was resolved in the post-Alpha stable push, by https://bodhi.fedoraproject.org/updates/FEDORA-2017-6f4667ac4d .

Note You need to log in before you can comment on or make changes to this bug.