Bug 143731 - hangs on modprobe -r ipt_state when stopping iptables after running pppd
hangs on modprobe -r ipt_state when stopping iptables after running pppd
Status: CLOSED DUPLICATE of bug 112630
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-25 18:12 EST by James Mckenzie
Modified: 2015-01-04 17:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 07:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Mckenzie 2004-12-25 18:12:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
After running pppd and shutting down pppd attempts to stop iptables
using /etc/init.d/iptables stop hang at modprobe -r ipt_state.  Cannot
kill -term or kill -kill the process.  A second attempt to run
iptables stop will hang.


Version-Release number of selected component (if applicable):
iptables-1.2.11-3.1.FC3

How reproducible:
Always

Steps to Reproduce:
1.run pppd to start up ppp session
2.stop pppd process
3.attempt to stop iptables or shutdown system with either -h now or -r
now.  Shutdown hangs at stopping iptables.  Stopping iptables in on
running system results in hung modprobe -r ipt_state process.
    

Actual Results:  Hung system waiting for shutdown or hung modprobe -r
ipt_state process.

Expected Results:  iptables should stop or system should shutdown or
restart.

Additional info:
Comment 1 Thomas Woerner 2005-01-10 05:52:10 EST
Assigning to kernel.

This seems to be similar to #144101.
Comment 2 James Mckenzie 2005-01-11 11:55:56 EST
Cannot access bug 144101 to verify if these bugs are alike.  Please 
add me to access.  Thank you.
Comment 3 Tadej Janež 2005-02-01 06:45:06 EST
This bug might me related to bug
https://bugzilla.redhat.com/beta/show_bug.cgi?id=112630
Comment 4 James Mckenzie 2005-02-26 23:04:02 EST
Close bug, I have stopped using FC3 and will revert to RH9 due to
multiple problems with FC3 and my system.  Will be changing to another
distribution that is more stable than FC3
Comment 5 Jay Turner 2005-03-01 07:33:31 EST

*** This bug has been marked as a duplicate of 112630 ***

Note You need to log in before you can comment on or make changes to this bug.