Bug 143733 - Sound choppy with static
Sound choppy with static
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-25 23:21 EST by Sean Walberg
Modified: 2015-01-04 17:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-15 18:30:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Walberg 2004-12-25 23:21:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
I upgraded my system from FC1 to FC3 via yum.  When playing sound,
either through XMMS, or even the GNOME system sounds, the output is
choppy, sounding like it is playing at a slower speed with static
thrown in to fill in the gaps.  The same hardware worked fine under FC1.

If I do something like grab a window and move it around the screen,
the sound works normally.

system-config-soundcard detects an Ensoniq 5880 AudioPCI card.  The
test sound exhibits the same behaviour as above.

Gstreamer is set for ALSA as both the source and sink.  I can not run
the test for the sink, though, I get "Failed to construct test
pipeline for 'ALSA - Advanced Linux Sound Architecture'".  However ESD
will test fine, but with the same behaviour.

[root@bob ~]# lsmod | grep snd
snd_ens1371            27557  4
snd_rawmidi            26725  1 snd_ens1371
snd_seq_device          8137  1 snd_rawmidi
snd_pcm_oss            47608  0
snd_mixer_oss          17217  2 snd_pcm_oss
snd_pcm                97993  2 snd_ens1371,snd_pcm_oss
snd_timer              29765  1 snd_pcm
snd_page_alloc          9673  1 snd_pcm
snd_ac97_codec         64401  1 snd_ens1371
snd                    54053  14
snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer,snd_ac97_codec
soundcore               9889  2 snd
gameport                4801  1 snd_ens1371
[root@bob ~]# uname -a
Linux bob.ertw.com 2.6.9-1.681_FC3 #1 Thu Nov 18 15:10:10 EST 2004
i686 athlon i386 GNU/Linux
[root@bob ~]# rpm -qa | grep alsa
alsa-driver-1.0.5a-1
alsa-lib-devel-1.0.6-5
gnome-alsamixer-0.9.6-2.fr
alsa-utils-1.0.6-3
alsa-lib-1.0.6-5




Version-Release number of selected component (if applicable):
2.6.9-1.681_FC3

How reproducible:
Always

Steps to Reproduce:
1.Run system-config-soundcard
2.Listen to test sound

    

Actual Results:  Choppy sound, playing at a slower speed, with static
thrown in

Expected Results:  A clear sound (or at least as good as a pair of $15
speakers will give)

Additional info:
Comment 1 Sean Walberg 2004-12-26 23:01:08 EST
My comment about moving a window seems a bit ambiguous.  Sound is 
fine while I'm moving the window around, it goes back to choppy once 
I stop.
Comment 2 Dave Jones 2005-07-15 15:22:27 EDT
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.
Comment 3 Dave Jones 2005-07-15 18:30:41 EDT
user mailed out-of-band..

"Thanks for the update, but I downgraded to FC1 to fix this problem.  If
I end up upgrading, I'll update the case with my results."

If this reoccurs, please reopen.

Note You need to log in before you can comment on or make changes to this bug.